Subgraves desfasados? (Smart)

  • 1
--46730--
#1 por --46730-- el 14/05/2009
Anteayer estuvimos midiendo la respuesta de un equipo master audio, ya que sopechasemos que uno de los subgraves estuviese fuera de fase con respeto a los otros 3. Para ello decidi cojer un micro AKG D112, enviarle ruido rosa con el smart (directo, sin crosover, ya que llevan DSP interno y filtran ellos solos) y sacar instantaneas de la grafica de fase de cada uno de ellos (todos medidos a 2m del centro del panel frontal). Lo cierto es que no estoy muy experimentado con smart, pero creo que algo si que pasa con ese altavoz, porque en la medicion de los demas, habia una coincidencia casi exacta, pero justo en ese la curva salía un poco desplazada hacia la derecha. Quiero, para ver si alguien me indica si hago lo correcto o no señalar 3 observaciones:

1- Al darle a la funcion AutoSM el smart no me detectaba bien la distancia en ninguno de los casos. Medi con el metro todas las mediciones a 2m, y el smart siempre me ponia que estaba a 10 y pico. La latencia de la tarjeta estaba a 2ms,pero bueno, en otras mediciones si me la detecto bien estando así. Al final estableci la distancia manualmente.

2-El ruido rosa lo saqué directamente del generador del smart, puenteando una de las salidas de mi tarjeta a una de las entradas con un cable ¿es correcto hacer esto? Es que estuve buscando como podia establecer en el smart que la señal de referencia fuese la del propio generador sin tener que andar puenteando en la tarjeta, pero no lo encontre ¿se puede?.

3- Os pongo a continuacion la instantanea de la fase. http://i292.photobucket.com/albums/mm39/Pablonovoa/PHASE.gif
La linea verde es la del altavoz de el que sospecho. La blanca y la naranja dos de los demas. El tercero aun no lo medi pero tampoco creo que haya problema. La respuesta en fase me da que es diferente, claro está. introduciendo delay en el DSP de ese altavoz conseguía igualarlo con el resto, pero entonces, ¿se trata de una inversión, o simplemete de una respuesta diferente por cualquier motivo que tengo que corregir con delay?
Observando la grafica por ejemplo, cerca de los 80 Hz (tan importantes!) hay una diferecia de unos 180º, o casi.
Si alguien que sepa mas que yo del tema me puede aconsejar, lo agradeceré yo,y todos los que estemos verdecillos con el Smart.
Un Saludo!!!
Subir
#2 por Luiser el 15/05/2009
Igual es una tontuna pero parece polaridad invertida en la medición de la línea verde #-o
Subir
Oficial
#3 por Nico Suárez el 15/05/2009
DrN escribió:

1- Al darle a la funcion AutoSM el smart no me detectaba bien la distancia en ninguno de los casos. Medi con el metro todas las mediciones a 2m, y el smart siempre me ponia que estaba a 10 y pico. La latencia de la tarjeta estaba a 2ms,pero bueno, en otras mediciones si me la detecto bien estando así. Al final estableci la distancia manualmente.


Deberías haber probado AutoLarge (tecla L). Para mediciones de sub habrás librado, pero para mediciones de full range el Autodelay debe hacerse como es. Y obtener un valor medianamente parecido a la realidad. Exácto no, por qué: interviene directamente la velocidad del sonido y esta es dependiente de temperatura y humedad. Además de la latencia de procesadores e interfaces. (Por ejemplo XTA introduce equivalente a 75cm más a la medición) Con lo cual si mides a 2 metros, un valor entre 1,9 metros y 3 metros debería estar bien. No esperes que el Smaart "clave" la distancia. Hay factores que no controla como humedad, temperatura y latencias...
El valor de distancia que muestra es referente al valor encontrado en ms convertido a distancia para una velocidad hipotética de 340m/s (aunque esto es modificable en las opciones): Recuerda que el nivel de los vúmetros ha de estar en amarillo (ambos) para ejecutar el autodelay. Y hacer el auto delay CADA VEZ que muevas el micro o el altavoz. Por muy cuidadosamente que lo hagas, quizás para frecuencias graves con un metro lo hagas medianamente bien, pero para medir frecuencias altas la cosa es más sensible; si 10KHz tiene de longitud de onda 3,4cm (para una velocidad supuesta de 340m/s, es decir, la distancia recorrida en su periodo, 0,1ms) una diferencia entre mediciones de 1,7cm sin haber hecho el autodelay le supondrá un desplazamiento de 180º.

DrN escribió:

2-El ruido rosa lo saqué directamente del generador del smart, puenteando una de las salidas de mi tarjeta a una de las entradas con un cable ¿es correcto hacer esto? Es que estuve buscando como podia establecer en el smart que la señal de referencia fuese la del propio generador sin tener que andar puenteando en la tarjeta, pero no lo encontre ¿se puede?.


Así es (ver imagen adjunta) lo único que hay que estar atento a que por ese canal no haya phantom (necesaria para el micro de medición) lo que tengan conector combo, suele ser necesario entrar por el jack, por el cual no viaja phantom. Hay posibilidades de cargarse la salida (una salida de un Mbox me costó aprender esto).
Los muy puristas te dirán que debes usar una sola salida del interfaz y con un cable en Y, porque indican que puede haber microdiferencias de tiempo entre una salida y otra. Pero bueno, yo tiro con ambas señales y hasta hoy...

DrN escribió:
La respuesta en fase me da que es diferente, claro está. introduciendo delay en el DSP de ese altavoz conseguía igualarlo con el resto, pero entonces, ¿se trata de una inversión, o simplemete de una respuesta diferente por cualquier motivo que tengo que corregir con delay?


Aplicando delay la pendiente empieza a bajar por la parte de las frecuencias altas. Serás capaz de igualar ciestas de las frecuencias graves pero ser un tanto "irreal". Me explico mejor, es ente caso conseguirías casi "plancharlo" ya que se trata de subgraves y todos iguales, pero si al hacer un ajuste en un corte entre low y high si el problema es una inversión de polaridad, por mucho delay que añadas tendrás que jugártela a un punto concreto para hacerlas coincidir, mientras que invirtiendo la polaridad (cosa muy común en el uso de filtros de 2º grado) el solapamiento en fase será en todo el tramo y no un punto concreto; con lo cual usemos la inversión de polaridad cuando sea necesario y el delay cuando lo sea. La gráfica es un caso clarísimo y típico de inversión de polaridad. No se si todo lo has probado con el mismo cable, sino el cable será. Si has probado con el mismo cable alguien de la fabricación a metido la pata pero bien!!!

Añado, no hay 180º de diferencia en 80Hz, hay 180º de diferencia en tooooda la gráfica. Tomando como tramo útil de medición entre 50Hz y 250Hz, lo cual es síntoma inequívoco de inversión de polaridad.

También podrías haber usado mediciones de impulso para certificar que es una cuestión de polaridad.

Para terminar dos apuntes;

Primero; sobre el autodelay, siempre hago autolarge porque es el único que tiene tecla rápida. Y porque es posible que mediciones cortas las detecte el auto large sin problema pero sin embargo a la "viceversa" no.

Y segundo, estaría bien poner Smaart con dos aes, que luego sino en las búsquedas de futuros hispasónicos no aparecerá. :mrgreen:

Mmmm llevo un rato releyendo el post y es como si se me olvidase algo...
Archivos adjuntos:
IMG_0595.JPG
BBCode:

http://www.educasound.com

Subir
--46730--
#4 por --46730-- el 15/05/2009
Nsv, chapó, me dan ganas de pagarte la clasecita xDDD. Gente como tu son las que marcan la diferencia en estos foros.
Tienes razon con la errata en el titulo (Smart) pero bueno ya no puedo editar.
Con respeto al tema del cable, pues si, he medido todo con el mismo cable. La sospecha de la inversion de fase era firme y entonces veo que esta ya confirmada. Veo que puedo aprender a fiarme ya un poco de mi oido.jejej.
Con respeto a la distancia ya te digo, haciendo pruebas en casa con autoSM me las clavaba, pero de decir, midiendo con el metro 2m y de ponerme 1.99 o 2.00, pero bueno, para mediciones con subgraves puede que se volviera algo tarumbilla. Ademas tengo en el ordenador una Emu 1212 de la que empiezo a tener sospechas serias, ultimamente se me esta portando mal.
Probare entonces a lo rápido a poner un cable invertido en ese altavoz, y ponerlo de ultimo, porque van todos linkados.
Con respeto a la medicion de impulso es algo que todavia no controlo mucho, pero me informare mejor entonces. Un Saludo.

Gracias por toda esa info y por las imagenes. Saludos.
Subir
Oficial
#5 por Nico Suárez el 15/05/2009
DrN escribió:
A (directo, sin crosover, ya que llevan DSP interno y filtran ellos solos)


Si pudieses acceder al DSP podrías invertir la polaridad desde ahí, es más, apuesto que el fallo está en el "preset" del sub o sea que lo que harías sería poner el preset correcto.

Si es un sub con un sólo cono, también podrías desatornillarlo y cambiar los cables, rojo por negro y negro por rojo.

Es posible que ese sub haya necesitado una sustitución del cono y el que lo cambió se equivocó al conectarlo...podría ser una explicación también, más probable que lo del DSP...

http://www.educasound.com

Subir
#6 por sacio100 el 15/05/2009
No es este el caso :roll: pero habia unas cajas de D.A.S. en las que ya de fabrica venia invertida la polaridad del tweeter por que era pasi el diseño .... :mrgreen:

no es este el caso evidentemente...pero tal y como se "fabrica" hoy donde los chicos de ojos rasgados, lo mismo la caja aun siendo nueva venia mal cableada
Subir
Oficial
#7 por Nico Suárez el 15/05/2009
Eso no es lo mismo sacio;

El caso es que entre 4 subs iguales y de igual marca UNO de ellos está invertido.

La inversión de polaridad relativa a vías distintas tiene su explicación en el uso de filtros de segundo orden.

El problema es; si uso un polarity check (mal llamados phase check) al analizar esa caja con esto nos dará; por ejemplo:

High Verde
Mid Rojo
Low Verde

En una caja supuesta de tres vías.

Si no se conoce bien este tema, invertiremos la polaridad de los medios pensando que así, todos nuestros transductores está en fase ahora.

PERO NO!!!

Quizás el diseño de esa caja esté hecho con filtros de segundo orden que requieren de esta inversión para poder hacer que en el punto de cruce ambos transductores sumen los esperamos +6.

Sin embargo, al hacer la inversión, con toda la buena intención; crearemos una cancelación total en el punto de cruce.

Pero... para qué son útiles los polarity checks entonces???

Por ejemplo en el caso original de este post, si medimos 4 cajas iguales, todas deben dar verde o rojo; indica que todas están en la misma polaridad.

Incluso las vias de todas las cajas (que no todas la vias de la cajas) deben dar la misma polaridad.

[Ejemplo, tengo 25 cajas modelo TRONATOR de la marca COOLSOUND, son cajas de motor+10'' de medios+15'' de graves:

Los agudos de las 26 cajas me dan verde.
Los medios de las 26 cajas me dan rojo.
Los graves de las 26 cajas me dan verde.

Significa que debo invertir todos los medios??? NO, es que la marca COOLSOUND usa filtros de segundo orden.

Por otra parte:

Los graves de 13 cajas dan verde, los graves de las otras 13 dan rojo.

ALGO PASA!!!! Manos al analizador y a qué cajas están bien y cuales mal, tantas posibilidades hay de que sea en "rojo" que en "verde".]

Yo tengo un polarity check en una bolsita que llamo SUB TOOLS, en donde además incluyo una cinta métrica para arreglos en línea y endfired, tiza para marcar en suelo su posición y un pequeño inversor de polaridad de cable, por si me ocurre el caso de nuestro amigo.

Fácil, pongo todos los subs y toooodos me deben dar verde o rojo, pero todos el mismo color y a partir de ahí trabajamos.

http://www.educasound.com

Subir
Oficial
#8 por Nico Suárez el 15/05/2009
Veamos unas gráficas.

Vía de graves; LPF corte a 1KHz, filtro de segundo orden (12dBs por octava) tipo Link-Riley (caída de 6 dBs en el punto de corte). Que produce un retraso de 90º

El trazo dorado es la fase. El rojo respuesta en frecuencia;

[attachment=1:3n79dbux]low.JPG[/attachment:3n79dbux]

Vía de agudo; HPF corte a 1Khz, filtro de segundo orden (12 dBs por octava) tipo Link-Riley (caída de 6 dBs en el punto de corte). Que produce un retraso (en el otro sentido) de 90º

El trazo dorado fase. El rojo respuesta en frecuencia;

[attachment=0:3n79dbux]high.JPG[/attachment:3n79dbux]

Total 90º + 90º = 180º de diferencia, que se anula con otros 180º

Si comparamos ambos trazos de fase es evidente una separación en todo el espectro de 180º, solucionable con una inversión de polaridad en cualquiera de las vías.

Esto producirá que al usar polarity check nos de colores distintos en las vías. Pero la suma en el punto de cruce se producirá. Si hacemos los contrario e invertimos (una vez más a parte de la que se hizo en fábrica) la vía, produciremos cancelación total en el punto de cruce.
Archivos adjuntos:
low.JPG
BBCode:
high.JPG
BBCode:

http://www.educasound.com

Subir
1
Oficial
#9 por Nico Suárez el 15/05/2009
Algo de esto ya se comentó en el tutorial de x-overs:
https://www.hispasonic.com/revista/intro ... crossovers

Alguien escribió:
Pero estas pendientes no son “gratuitas”; producen un retraso que se acusa en fase de la siguiente manera:

Primer orden – 45º
Segundo orden – 90º
Tercer orden – 135º
Cuarto orden – 180º
Quinto orden – 225º
Sexto orden – 270º
Séptimo orden – 315º
Octavo orden – 360º

x-overs%2012.jpg

Fruto de la combinación de estos filtros con sus respectivos desfases, podríamos tener que hacer uso del anteriormente mencionado cambio de polaridad.

http://www.educasound.com

Subir
1
#10 por sacio100 el 15/05/2009
=D>
ya he dicho que no era lo mismo y en este caso si las cajas son nuevas es fallo de fabricacion y si no pues el dia de la reparacion el que la hizo estaba pensando en carla bruni cantado heavy :lol:

pero aun asi tu explicacion como siempre CHAPEAU !!!!

dime si tienes este verano algun bolo por la zona Burgos/ Vitoria por que estas invitado incluido alojamiento jajaja

Un saludo y lo dicho "maestro"....
Subir
Oficial
#11 por Nico Suárez el 15/05/2009
lo más cerca Bilbo, jajajajaja

http://www.educasound.com

Subir
--46730--
#12 por --46730-- el 17/05/2009
Magistral si señor.
Con respeto al tema del dsp, el preset si que era el mismo establecido en cada sub, ademas, buscando el los menus y en las opciones, no encotre por ningun lado el inversor de fase, creo que no tiene.
Otro tema es que a los subs le fueron cambiadas las etapas, las primeras que traian no eran el modelo que venía procesado por dsp, y ahi fue donde sospechamos que realizaron mal el cambio y dejaron una caja invertida.
Cada caja por cierto es de doble cono invertido. Tenemos una en reparacion porque le falla uno de los canales de la etapa, pero ayer en Orense probamos una actuación, y puse un cable invertido en la caja que se supone invertida y creo que si mejoró la difusión en subs. Digo "creo" porque el sitio no era muy grande, el control lo tenia cerca del escenario y estabamos rodeados de edificios.
Eso si, sigo teniendo un problema con el smart y es que no me detecta bien la distancia y en corto ni en largo. ¿cual es el problema?
Subir
Oficial
#13 por Nico Suárez el 17/05/2009
Ya tienes la solución al enigma.

Centrémonos en lo del autodelay:

Conexionado.

Por un lado bucle entre una salida y la entrada de referencia del interfaz.
Por otro lado otra salida al equipo (sin compresores o limitadores).
Y a una entrada el micro de medición. Revisa que esté bien...

Generador ruido rosa del propio smaart ON.

Vúmetros, tanto el de medición como el de referencia en el nivel amarillo.

Ejecutar el autodelay.

Ver como el trazo se estabiliza.

Como saber si está bien. Mostrando el trazo de coherencia, si el autodelay no está bien hecho la tendencia general de la coherencia es a 0%. Si el valor del autodelay está mal por muy poco sólo se mostrará mala la coherencia de las frecuencias más altas.

No sé... está todo bien?

http://www.educasound.com

Subir
--46730--
#14 por --46730-- el 18/05/2009
Ok revisare el sistema de conexionado, que creo que si que esta bien, y que los limitadores del sub este desactivado.
Ahora bien. En caso de que hubiese una latencia fija por el tema del DSP (me refiero a una latencia apreciable), asi como puede ocurrir por ejemplo midiendo con un X-over, supongo que podremos y deberemos indicarselo al smart para que trabaje adecuadamente. Lo mismo que le indicamos por ejemplo la temperatura ambiental... Es que ahora hago pruebas en casa de la misma manera, y ¡¡me las clava de nuevo!! #-o

Y el tema de las cajas desfasadas a proposito, es siempre en relacion a vías diferentes ¿no? por el tema del filtrado.
Por cierto, y viendo cual va a ser mi proxima adquicisión, jejej, el polarity check que utilizas ¿que modelo es? porque me interesa de forma orientativa saber como son y como funcionan, como hacen para detectar la polaridad en un altavoz, en un cable... es que soy el tipico que siempre desconfia de todo, y, es tan facil dudar de los cables siempre... pero con el poco tiempo que hay, lo largas que son las mangueras.... yo utilizo un simple cheker para cables, destos que son cilindricos y largos, creo que cuando un cable esta invertido uno de los led no enciende, pero bueno, muchas veces hay que tirar del polimetro y testear con eso es un coñazo. y mas cuando en una manguera llena de apaños debido a que ya le han pasado toneladas de automoviles con mala leche por encima...
Ademas, si es una forma muy rapida de saber la polaridad de un altavoz dispositivo nos ahorramos el smart y las graficas ¿no? :mrgreen: ui si lo supiera antes....
Venga un saludo a todos
Subir
#15 por eliezer el 18/05/2009
DrN escribió:

Ademas, si es una forma muy rapida de saber la polaridad de un altavoz dispositivo nos ahorramos el smart y las graficas ¿no? :mrgreen: ui si lo supiera antes....
Venga un saludo a todos


El polárity check no sustituye al smaart. Pero puedes ahorrarlo con el smaart que si puede sustituir al polárity.
Si dos cajas suman es que están en fase. Si no suman están en contrafase.
El Smaart te ofrece muchísimo mas que, simplemente, ver la polaridad de la scajas.

Lo de las latencias del procesador no necesitas decírselo al smaart. El smaart mide todo. No le importa si el delay medido es por la distancia o por latencias. Simplemente sabe cuanto tarda el sonido que mandas al sistema en llegar a ti de vuelta y punto.

Si el Smaart no es capaz de medir de forma estable la distancia puede ser por que estés demasiado lejos de los altavoces.
Cerca de los altavoces, el micro de medición detecta de forma clara el sonido directo que tiene un nivel claramente mayor que el reverberado o rebotado por el local.
Pero si te alejas llega un momento en que el sonido reverberado por la sala se confunde con el directo de los altavoces. Quizá por ahí vaya tu problema.

¡Atención. Peligro!.
¡Autodidacta opinando como si supiera!.

http://nextinge.wordpress.com/

Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo