Velocidad Carga Temas Traktor X1

Vareland
#1 por Vareland el 15/12/2019
Saludos foro,

Finalmente adquirí una controladora X1 MKII para unir a mi equipo y así poder manejar Traktor Scratch de una forma más eficiente.

El único problema que me ha surgido, y por el cual acudo a vosotros, es sobre lo que reza el titulo del hilo, lo que puede llegar a tardar a cargar un track en un deck cuando lo hago mediante el botón BROWSE de la X1.

Os resumo rápido:

- Antes de tener la controladora lo hacía obviamente con el ratón del PC, clickaba con el botón derecho encima del track y le indicaba si lo quería en el DECK A o DECK B. La carga era instantánea. Cuando surgió este inconveniente con al X1 volví a probar y seguía yendo igual de bien, pero más incómodo porque no uso un portátil sino un sobremesa que esta en otro angulo y tengo que estar cogiendo el ratón constantemente.

Con la X1 MKII, en muchísimos tracks me encuentro con que, al darle al botón de carga del DECK correspondiente, se demora la carga entre 10, 20 e incluso 30 segundos, lo cual me parece anormal.

La librería de tracks que manejo es de unos 28000 tracks y tengo playlists de unos 200/300 cada una. Todos los temas son MP3 y han sido Analizados por Traktor y añadidos a la colección (tardó casi 2 dias en leerlo todo xD)
También tengo desmarcada la opción en Traktor de "ANALIZE NEW TRACKS WHEN LOADING INTO TRACK" y la de "ANALIZE NEW IMPORTED TRACKS", por lo que descarto que sea un problema de que tenga que analizar cada track al cargarlo.

Y también en la librería a veces desaparece el listado de tracks para mostrar el mensaje "PLEASE WAIT WHILE FILTERING".

Mirando el VU sobre la carga de procesos que tiene la CPU no llega en ningún momento ni siquiera a la mitad, como mucho a 1/4 del total.

El equipo de sobremesa con Windows 10 es el siguiente:

i5 4460 a 3,20ghz
Ram 16GB
GTX 750 Ti

La música carga desde un HDD Externo USB 3.0

El software es Traktor Scratch Pro 2.11.3 el cual uso únicamente con una Audio A6 y dos Traktor Control Vinyl MKII y dos Technics y una Rodec CX1100.

Por descartar que fuese problema de los archivos MP3 he usado estos días Virtual Dj 8 y allí la carga es instantánea tanto con el ratón como con la X1. El problema es que el Timecode no va tan preciso como con Traktor (imagino porque no uso los vinilos mas adecuados, aun configurando Virtual DJ con las opciones correctas) así que tampoco lo valoro como opción para adquirirlo.

Crees que actualizando a Traktor 3 podría solucionar este asunto? Ya puestos me merece la pena pagar 50€ de la actualización?

Finalmente os dejo un vídeo donde se aprecia el problema.



Disculpad por el soberano tocho, pero quería dar toda la info posible para ya de entrada despejar algunas dudas.

Un saludete y gracias de antemano!!
Subir
Teo Tormo
#2 por Teo Tormo el 15/12/2019
Mira en las preferencias que no tengas marcada la opción de "Load only into stopped decks", porque aunque esté parado el tema cuando se usa DVS mucha gente se ha quejado de que Traktor hace cosas raras como esta que describes, y al parecer a algunos se les solucionó quitando esa opción. Hay gente quejándose de esto desde 2016 o antes creo, e incluso con Traktor 3 ha aparecido gente en el foro con problemas similares. No hay una explicación oficial.
También es posible que sea cosa del controlador, mira que esté el firmware actualizado descargando el "Device Updater" del cacharrito, cuando no están con el último firmware pueden hacer cosas como enviar comandos que confunden al programa.
Subir
Vareland
#3 por Vareland el 15/12/2019
#2 Buenas maestro, pues la opción la tenia marcada. Voy a probar lo que comentas y esperemos sea la solución.

He descargado el Device Updater y pone que estoy al dia, pero con una cosa curiosa. Me dice que la version que tengo instalada es la 16 y la ultima disponible es la 11...

Pongo captura para que veas a que me refiero:


d3a9991072a387183051e33fc2aa9-4628907.jpg
Archivos adjuntos ( para descargar)
Captura.jpg
Subir
Vareland
#4 por Vareland el 15/12/2019
Pues después de probar con unos cuantos tracks sigue ocurriendo, tanto con la opción tanto marcada como desmarcada, así que deduzco que el problema esta en otro sitio.

Es raro, ya que igual se debe a como gestiona Traktor la carga de los tracks desde la Controladora. Lo que sorprende es que Virtual Dj, con la misma controladora, el mismo cable, en el mismo puerto USB y los mismos archivos, los cargue de forma instantánea.

Y aún más raro es si hago la carga de los tracks con el mouse, botón derecho y LOAD INTO DECK A o B según proceda, también se carga el track de forma instantánea...
Subir
Teo Tormo
#5 por Teo Tormo el 15/12/2019
Vareland escribió:
Y aún más raro es si hago la carga de los tracks con el mouse, botón derecho y LOAD INTO DECK A o B según proceda, también se carga el track de forma instantánea...

Esto lo había pasado por alto y ahora releyendo veo que lo habías puesto antes, y claramente es indicativo de un conflicto entre el controlador y el programa.
Prueba a hacer una reinstalación limpia del programa, porque suena a que el mapeo hace algo más que enviar un mensaje de carga en el deck. Lo del firmware ni idea, obviamente no tiene sentido, o el sentido sólo puede dárselo NI con alguna explicación.
Subir
Vareland
#6 por Vareland el 15/12/2019
Probaré a reinstalar Traktor de nuevo.

Un dato que no se si es crítico es que el X1 no lo he comprado nuevo sino de segunda mano. Puede ser que contenga alguna configuración en su memoria del anterior propietario que cause conflicto con mi Traktor?
De ser así hay alguna forma de dejar la X1 de fábrica? Un hard reset o algo por el estilo que la deje nueva de fábrica.

He de decir que el anterior dueño lo usó 3 veces literalmente hablando, e incluso no había ni registrado el numero de serie en su cuenta de NI. Digamos que mi usuario es el primer dueño a efectos de licencia del device.

Yo en Traktor no tengo nada mapeado.

Saludos y gracias por tu tiempo Teo.
Subir
noob!
#7 por noob! el 16/12/2019
#6 el load sube casi a la mitad, cuanto tiempo hace que no formateas el pc? tienes muchos programas que inicien solos y estén ocupando procesos?

:birras:
Subir
Vareland
#8 por Vareland el 16/12/2019
Buenas, pues instalé Windows 10 en Septiembre, por lo que no hace mucho.

En el arranque de Windows no tengo ningun programa cargado mas allá del gestor grafico de NVIDIA, el Windows Defender, Administrador de Sonido de Realtek y Serviio (para el DLNA en casa).

Mientras hacia mas pruebas me he estado fijando que solo sube en el momento de hacer el LOAD del track. Una vez cargado todo fluye bien y no se inmuta apenas.


Mañana probaré una solución que me ha venido a la cabeza:

- Dado que con el ratón y haciendo click derecho y "LOAD INTO TRACK DECK A" (o B segun proceda) hace la carga de forma normal y rápida, voy a probar de mapear en la X1 esta acción como si la realizase desde el PC. Quizás así "engaño" al programa haciéndole creer que es un click del ratón, o que al menos lo entienda y lo ejecute de la misma forma.

No se si será posible pero por probar.


Saludos.
Subir
Teo Tormo
#9 por Teo Tormo el 16/12/2019
#8 Pon el trasto en modo MIDI (shift + los dos botones de carga) y mapealo como si fuera un controlador nuevo, a ver si lo hace.
Subir
1
Vareland
#10 por Vareland el 17/12/2019
Buenas, finalmente he probado el mapeo de los botones de carga de la X1 para que actúen, creo, como si hiciese la carga de los tracks con el raton, es decir:

- Boton Derecho sobre el track y seleccionar "LOAD INTO TRACK DECK A" (o B segun proceda)

7ef19a522e3dcb14db7874cefef65-4629113.jpg

Dejo captura de como lo tengo en preferencias, por si le sirve de ayuda a alguien que se encuentre con este problema.

681045249d57f3df874a477f809ec-4629113.jpg

De momento no me ha dado problemas, pero .... ya te vale NI....

Mil gracias por vuestros consejos. Teo, si veo que me vuelve a dar por saco, probaré lo del mapeo en Modo MIDI.


Saludos!!
Subir
Hilos similares
Responder

Regístrate o para poder postear en este hilo