Ayuda rme

  • 2
Robakun
#16 por Robakun el 03/03/2006
Ah, pues miraré en la web de alsa. En ubuntu no están los paquetes de alsa-tools-gui, ni alsa-tools.

Si logro usar la rme con demudi por ejemplo, ¿cómo copio la configuración?
Subir
Ismael Valladolid Torres
#17 por Ismael Valladolid Torres el 04/03/2006
Vas a necesitar alsa-tools-gui y alsa-firmware-loaders. ¿Te atreves a añadir los repositorios de Debian a tu /etc/apt/sources.list? Podrías configurar las preferencias de apt para que sólo use estos paquetes de Debian sid, pero esto son técnicas avanzadas. Aunque bien pensado, ¿que no son técnicas avanzadas con Linux? :)

O bien utilizar la rama inestable de Ubuntu en lugar de Debian sid.

http://mundogeek.net/archivos/2004/11/2 ... en-ubuntu/
http://www.ubuntu-es.org/node/595
Subir
Robakun
#18 por Robakun el 04/03/2006
Y no puedo bajar esos paquetes, por otra vía, por ejemplo cvs, con sus dependencias? Esque lo demás va muy bien, y si mezclo le repositorios...bueno no se.
Subir
--6355--
#19 por --6355-- el 04/03/2006
Robakun escribió:
Y no puedo bajar esos paquetes, por otra vía, por ejemplo cvs, con sus dependencias? Esque lo demás va muy bien, y si mezclo le repositorios...bueno no se.


Te puedes bajar las fuentes y compilarlos tú mismo.Si al final del proceso utilizas checkinstall tendrás un paquete deb que puedes gestionar con apt o dpkg,lo cual te asegura una desinstalación limpia en caso de que no te funcionen.

Saludos.
Subir
Ismael Valladolid Torres
#20 por Ismael Valladolid Torres el 04/03/2006
Robakun escribió:
Y no puedo bajar esos paquetes, por otra vía, por ejemplo cvs, con sus dependencias? Esque lo demás va muy bien, y si mezclo le repositorios...bueno no se.


Con las indicaciones en esos enlaces, sólo los paquetes que necesitas vendrán del nuevo repositorio, el resto quedarán intactos.

El peor de los casos es que tengas que reinstalar el sistema, habiendo aprendido un huevo. En otros sistemas también hay que reinstalar sin haber aprendido una mierda.
Subir
Robakun
#21 por Robakun el 07/03/2006
Hola, a ver si esta semana tengo más tiempo de meterle mano al tema. Sólo decir que no puedo hacer muchos malabares porque el ordenador no es mío y no tiene un adsl, sino un moden que no suele alcanzar los 30k. Por eso usé los repositorios DVD. (Por cierto esto es una situación que podría darse, por ejemplo en la oficina de una ONG: usa software libre, pero no tiene necesariamente adsl. Los repositorios en DVD o en un disco usb, serían una buena solución, no?)

Os iré contando y preguntando...

Sólo reportar que este sitio puede estar bien para la combiación ubuntu+sonidoymúsica

http://ubuntustudio.com/wiki/index.php/ ... sicians%21

aquí, cómo convertir ubuntu breezy en un studio:

http://ubuntustudio.com/wiki/index.php/ ... reparation
Subir
danner
#22 por danner el 13/03/2006
Robakun, cuando dices que jackd se queda intentando arrancar infinitamente, estás seguro que no es, simplemente que jackd está funcionando? No te tiene que salir ninguna ventana ni nada de eso, simplemente verás que, desde alguna aplicación que soporte jack (jack-rack, por ejemplo) te dirá que jackd está funcionando (o, en su defecto, no se quejará porque no lo esté ;) )

Por cierto, gracias por el enlace de ubuntustudio.com
Subir
Robakun
#23 por Robakun el 14/03/2006
Hola danner, se me han dado tres situaciones

- con la rme al dar a start sale el mensaje de error, como el que puse más arriba
- con la via (la de la placa) no llega a salir ningún indicador de que esté funcionando. En otro ordenador si he usado jack, entonces tengo una idea de lo que tiene que pasar.
- con la vía (si selecciono h:0,2 en vez de h:0,0 como entrada y salida)arranca jack con varios xruns cada pocos segundos. Funciona, pero noto distorsión en el sonido, y pequeños cortes. Hago la prueba con pd en tiempo real, y no suena bien. Por una cuestión que aun no entiendo bien, ubuntu breezy tiene dificultades para correr jack sin xruns, según pone en la web de ubuntustudio.


Pude en un rato meter un cd-live de demudi, y tampoco pude arrancar jack con la rme. Por cierto, no se si lo he dicho, pero buscando información, creo que en la siguiente versión de ubuntu que sale en abril si tendrá los paquetes de alsa que decían guitman e ivallardt, en los repositorios. Se avanza muy rápido, eh? que maravilla
Subir
Ismael Valladolid Torres
#24 por Ismael Valladolid Torres el 27/07/2007
Bien que lamento haber tardado tanto en responder a este tema, pero es que ¡hasta hace unos días no he vuelto a tener mi RME Digi96/8 montada!

La cuestión es que jackd se niega a permanecer arrancado si la RME tiene seleccionada como entrada una digital a la que no hay nada conectado (por ejemplo la S/PDIF coaxial o la ADAT óptica) y por desgracia una de las dos es la seleccionada por defecto recién arrancado el sistema. Usa rmedigicontrol en el paquete alsa-tools-gui o el propio alsamixer para seleccionar la entrada analógica o ninguna. Es posible que también haya que subir el nivel del DAC en alsamixer para que suene algo una vez que jackd arranque y se quede arrancado.

Por otra parte, no todos los valores para el argumento -p (frames per period) son aceptados por jackd. A mí me funciona con 256. Habrá que jugar después con el número de periodos -n para encontrar alguno estable con una latencia suficientemente baja. Creo recordar que en mi máquina con -p 256 -n 2 tengo 11 ms de latencia sin ningún problema de estabilidad.

Todo esto en realtime por supuesto.
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo