Drivers Asio e Instrumentos VST

  • 1
srcsrc
#1 por srcsrc el 24/11/2003
Hola. El otro día me dió por probar los instrumentos VST en el sonar, pero me van muy lentos (retardo desde que toco el teclado).
El caso es que le cambié la configuración, poniendo los drivers asio y va mejor, pero sigue tardando un poco, y es imposible tocar así.
Mi tarjeta es una Sound Blaster Audigy, tengo un pentium IV a 2'1, y 512 de Ram, así que no creo que sea el equipo.
La cosa es que cuando grabo algo en midi, y luego lo paso a la pista del VSTi, lo reproduce correctamente, pero no puedo grabar directamente en la pista VSTi, porque se retrasa.
Una ayuuuuuuuuuuda :cry:
Gracias.
Subir
ArkaNoise
#2 por ArkaNoise el 24/11/2003
Cuando seleccionas los drivers asio debería haber alguna opción para configurar el tiempo de latencia, algo como "Asio control panel", al menos en mi SX es algo asín... En el sonar no t puedo dcir pero seguro q anda por ahí. Estas usando los vst con algún adaptador vst a dx? O es q el sonar acepta directamente vst?
Subir
Bartos
#3 por Bartos el 24/11/2003
srcsrc escribió:
Hola. El otro día me dió por probar los instrumentos VST en el sonar, pero me van muy lentos (retardo desde que toco el teclado).
El caso es que le cambié la configuración, poniendo los drivers asio y va mejor, pero sigue tardando un poco, y es imposible tocar así.
Mi tarjeta es una Sound Blaster Audigy, tengo un pentium IV a 2'1, y 512 de Ram, así que no creo que sea el equipo.
La cosa es que cuando grabo algo en midi, y luego lo paso a la pista del VSTi, lo reproduce correctamente, pero no puedo grabar directamente en la pista VSTi, porque se retrasa.
Una ayuuuuuuuuuuda :cry:
Gracias.
el tema no está en el procesador que tengas o la memoria ram (aunque todo influye), está en la tarjeta en gran parte. , ¿has visto si soporta asio y que latencia tiene?, cuando tocas algo via midi y luego pasas esa pista a una pista de un intrumento vst no vas a tener ese problema ya que es el secuenciador el que dispara el sonido, no tú con un teclado maestro, mira a ver que latencia tiene esa tarjeta. o si soporta asio.

un saludo.

link recomendado
http://www1.dragonet.es/users/musicasa/ ... tencia.htm
Subir
srcsrc
#4 por srcsrc el 24/11/2003
El sonar 3 incluye el Cakewalk VST Adapter 4.3.
Lo de configurar el tiempo de latencia no te lo puedo decir ahora, porque no estoy en mi casa. Esta noche lo veré.
¿Afecta que sea un adaptador?.
Lo digo porque en el Cubase tampoco me funcionaban bien los VSTi, aunque claro, no se si estaban configurados los Asio, y la verdad es que nunca había usado el Cubase.
Subir
Peinacabras
#5 por Peinacabras el 24/11/2003
Yo estoy en la misma situacion de srcsrc. Tengo la live 5.1 y kx project como driver asio, (asio kx en cubase vst 32). Con audio me van fenomenal (5ms de latencia), pero cuando esta funcionando algun instrumento vst tengo latencia, igual q cuando toco el teclado conectado al ordenador, latencia. ¿Alguien sabria decirme algo?. Gracias.
Subir
srcsrc
#6 por srcsrc el 24/11/2003
BARTOS escribió:
¿has visto si soporta asio y que latencia tiene


La SB Audigy sí soporta Asio pero lo de la latencia ¿Donde se mira?
Subir
ArkaNoise
#7 por ArkaNoise el 24/11/2003
Supongo que no depende si usas adaptador, era curiosidad mia. Lo de la latencia se mira donde te dije, en el "asio control panel", a mi en cubase se me activa al seleccionar los asio. Tengo la audigy2, supongo q serán casi iguales así que mira x ahí. En cubase esta en Dispositivos>configuracion, creo.
Subir
Peinacabras
#8 por Peinacabras el 24/11/2003
Alguien me puede decir algo a mi???? Por favor. Yo tengo 5 ms donde tu dices arkanoise, con audio fenomeno, pero con vsti y tocando el teclado conectado al ordenador latencia. Alguien me dice algo????
Subir
ArkaNoise
#9 por ArkaNoise el 24/11/2003
Peinacabras, yo tb tngo 5ms y apenas se nota la latencia, siempre puedes probar a bajarla 2ms pero pueden sonar chasquidos..
Subir
Peinacabras
#10 por Peinacabras el 24/11/2003
Si, la puedo reducir muchisimo en audio, pero corro el riesgo delos chasquidos. Pero con los 5ms de latencia a ti no te producen latencia los vsti ni tocar el teclado conectado al ordenador???????. De todas formas probare a bajar la latencia a ver si mejora. Gracias al menos me has respondido, empezaba a tener complejo de hablar solo, tengo este mismo tema sobre otros del hilos y no obtengo ideas. Gracias de nuevo:-)
Subir
ArkaNoise
#11 por ArkaNoise el 24/11/2003
Alguien escribió:

Pero con los 5ms de latencia a ti no te producen latencia los vsti ni tocar el teclado conectado al ordenador???????.

Practicamente nada, no se que podrá ser lo tuyo...
Subir
JoseCM.
#12 por JoseCM. el 24/11/2003
srcsrc escribió:
Hola. El otro día me dió por probar los instrumentos VST en el sonar, pero me van muy lentos (retardo desde que toco el teclado).
El caso es que le cambié la configuración, poniendo los drivers asio y va mejor, pero sigue tardando un poco, y es imposible tocar así.
Mi tarjeta es una Sound Blaster Audigy, tengo un pentium IV a 2'1, y 512 de Ram, así que no creo que sea el equipo.
La cosa es que cuando grabo algo en midi, y luego lo paso a la pista del VSTi, lo reproduce correctamente, pero no puedo grabar directamente en la pista VSTi, porque se retrasa.
Una ayuuuuuuuuuuda :cry:
Gracias.


A ver:

1. ¿Has hecho funcionar Wave Profiler (menu>options>audio)?
2. ¿Una vez lanzado wave profiler, que latencia mínima te aparece a la izquierda del control deslizador?
3. No tengo mucha idea de cómo van los drivers de la Audigy, pero no asumas que necesariamente te tienen que ir mejor los ASIO que los WDM con Sonar. Depende de tu tarjeta y tus drivers. A mí me da 1.5ms de latencia mínima con WDM en una ESI WT2496. Los drivers ASIO sólo los uso para Reason.
4. ¿Qué quieres decir con "grabar directamente en la pista VSTi"? En Sonar no hay ninguna diferenciación entre una pista normal y una "VSTi" o "DXi". Lo normal es grabar en la pista midi y luego hacer "Bounce to tracks" a la de audio, o ni eso y mezclar todo del tirón.

Saludos,

JoseC.
Subir
srcsrc
#13 por srcsrc el 25/11/2003
Ayer probé lo de reducir latencia a 5 ms: Eureka. :wink:
Pero un error: Los instrumentos VSTi, casi una pasada, porque iban a tiempo real, sin latencia, pero con unos chasquidos (normales por lo que veo), pero que eliminé al subir la latencia a 7 ms.
En esa configuración no había ni retraso ni chasquidos. Acojonante... O no!!!
:x
Después de grabar una pista con un sinte virtual, muy tecno, le quise meter guitarra, Y... ¡No graba ningún sonido ni por la entrada auxiliar, ni por el line in, ni siquiera habilitando la entrada "lo que se oye" de la Audigy.
El caso es que he descubierto la solución: Para grabar audio hay que desahilitar los driver asio, y habilitar "la mejor configuración por defecto".
El problema es que hay que reiniciar el sonar.
Pero no importa. Primero grabo todo el midi y los VSTi, lo guardo, cambio drivers, cierro, abro, y grabo audio.
Joer que rollo, pero funciona.
Se os ocurre algo mejor?
Subir
JoseCM.
#14 por JoseCM. el 26/11/2003
srcsrc escribió:
Se os ocurre algo mejor?


Aparte de cambiar de tarjeta, poca cosa, salvo que insistas, porque aunque la Audigy no sea para tirar cohetes debería funcionar aceptablemente sin necesidad de hacer cosas raras.
Subir
pingfloid
#15 por pingfloid el 29/11/2003
Hola güenas,

Yo utilizo el Sonar-3 con una tarjeta ESI Waveterminal 192M y mi experiencia, hasta ahora, es la siguiente:

- En el panel de la ESI fijo la latencia a 48 o 64 sample.
- En Sonar\Options\Audio\Advanced selecciono el driver WDM/KS.
- No noto ningun retraso al ejecutar instrumentos VST diréctamente desde el teclado.
- No noto ningun retraso al ejecutar efectos VST en tiempo real sobre la entrada de audio (monitorizando la salida de audio procesada). Incluso puedo tocar la guitarra a través del "Amplitube" (ese plugin es una pasada; mejor que una montaña de altavoces Marshall)

Mi único problemilla, de momento, es que cuando realizo el "Bounce to tracks" al Steinberg Grand Piano se cortan las notas.

He probado con otros instrumentos VSTi y DXi, pero solo me ocurre con el Grand Piano. Es una pena, ya que es el mejor sonido de piano que he escuchado. Para pasarlo a audio tendré que hacer la burrada de conectar una salida de audio a una entrada de audio, con la consecuente pérdida de calidad por las conversiónes digital/analógico/digital.

¿Algún otro usuario de la 192M por ahí?
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo