Kontakt-Focusrite 2i4-Delay en MIDI

Jesus Rodriguez
#1 por Jesus Rodriguez el 29/08/2019
Para ir al grano:

Equipo: Focusrite 2i4 2nd generación (nueva, drivers actualizados, todo instalado al 100%)
DAW: Protools
Librería VST: Kontakt 6 (recién compradito también)
Entrada Midi: Clavinova, cable MIDI conectado directamente a entrada MIDI Focusrite 2i4

Todo bien configurado en Protools. Se oye, se puede grabar, etc,etc. Todo Ok.

PROBLEMA: Un Delay extremo cuando trato de grabar en una pista MIDI conectada a un Instrumento VST de Kotakt al modo usual y ortodoxo.
Desde que pulso una tecla (ya sea desde mi Clavinova o en el mismísimo teclado virtual de Protools 12 o incluso del mismo Kontakt) delay de 0.3 sg (una burrada, imposible tocar mientras se escucha el sonido VST y el resto)

¿Hay solución a esto? Posibles respuestas:
1) El problema es Kontakt que implica Delay sí o sí y no hay solución. Por tanto no se puede tocar MIDI ya ala vez escuchar el VST
2) Hay gente por ahí que con lo mismo, toca a la perfección.(Ójala sea esta) Y la solución es hacer lo siguiente:..........(solución)
3) Si quieres componer música con VST Kontakt + Protools + lo que sea tendrás que usar una tarjeta PCI mucho más rápida o profesional
4).....ya me diréis qué se os ocurre.



Mi ordenador es bastante potente (16Gb RAM, Pentium i7, USB 2 o 3........ vamos que la máquina no es)

Mi impresión es que es Kontakt.... pero no sé si por ahí hay alguien que sí que está siendo capaz de componer pista a pista con teclado MIDI e instrumentos VST Kontakt + DAW tipo Protools, y es capaz de tocar cada nueva parte mientras escucha el resto o al menos, parte del resto.

Un saludo y cualquier ayuda se agradecerá.

PostData: Gracias a "Australia" por indicarme cómo crear hilos y cositas parecidas por estos lares.
Subir
Inxu
#2 por Inxu el 29/08/2019
#1

Parece que tienes un problema grave de latencia,,, chekea el tamaño del Buffer en tu interface,,, bufer mas pequeño , latencia mas pequeña,,,bufer mas grande , mayor latencia y mayor capacidad de proceso para tu maquina,,, a si a lo groso somero , bufer bajo para grabar bufer grande para mezclar,,,,

Puede que haya algun truco mas en protools, no es un DAW que conozca bien , a ver si alguien puede aportar mas ,, saludos
Subir
Jesus Rodriguez
#3 por Jesus Rodriguez el 29/08/2019
Gracias x contestar: el buffer lo puedo poner a 64 (un burrada de pequeño....pero por probar) y le importa un pepino al MIDI. Nada.delay total y ni puñetera idea de por qué.
:-(
Subir
Jesus Rodriguez
#4 por Jesus Rodriguez el 30/08/2019
Solventado:
Por si a alguien le sirve. La Scarlett 2i4 funciona de miedo, sin latencia aparente. El problema es tratar de usar dos altavoces Denon que suenan de maravilla pero no son para monitorear sino para otras cosas, como uso Bluetooth.

Todo el delay se debía a ellos. Todo. al parecer, estos altavoces, incluso usados con clavija en vez de Bluetooth, tardan un rato en en proceso de captura y ese "rato" me estaba volviendo mico.
Realmente quería usar estos altavoces Denon porque suenan de miedo....pero, al parecer no va a poder ser.
Moraleja: Usar siempre altavoces/monitores a tal efectoi, no los que tengan también conexión Bluetooth.

La cosa me ha llevado 4 largos días..... para una bobá....pero hasta que no te pasan estas bobás, no aprendes.

En fin. Que ya está.
Subir
robinette
#5 por robinette el 31/08/2019
Jesus Rodriguez escribió:
Todo. al parecer, estos altavoces, incluso usados con clavija en vez de Bluetooth, tardan un rato en en proceso de captura

Eso si que es extraño. :-k
Lo del bluetooth vale (se sabe que la trasmisión de audio por bluetooth genera latencia), pero que conectándolos por cable también genere latencia...
No se puede llegar a la conclusión que mencionas en tu "moraleja" así sin más. Creo que faltan datos en mi opinión.

¿Qué modelo de altavoces Denon son los que te han generado ese delay?, ¿cómo lo tenías todo conectado y cómo lo tienes ahora?, ¿con qué monitoreo has dejado de tener esa latencia?.

Un saludo.
Subir
Jesus Rodriguez
#6 por Jesus Rodriguez el 01/09/2019
En efecto, Robinette, es , más que extraño, raruno.... pero me lo debí imaginar:

Los altavoces son dos Denon Endaya 250. Son absolutamente maravillosos: para mí lo mejor que he escuchado en un tamaño tan pequeño.

¿Cuál fue el problema-despìste idiota por mi parte?

Conectar directamente uno de los Denon (con una clavija stéreo, dado que esa es la entrada que hay que introducirle) y el otro (aquí hay redoble) se sincroniza con el anterior vía bluetooth. Y ese creo que es el quiz de la cuestión: esa sincronizaión vía bluetooth entre ambos implica claramente un delay que no se nota lógicamente para empezar a escuchar música, pero sí cuando lo usas como salida de controlador MIDI.

¿Se podría probar con dos cables directos a ambos? Pues supongo que sí, la verdad es que eso no lo probé.

Tras el chasco, he decidido pasar directamente a unos monitores diseñados ex-profeso para lo que yo quiero y dejarme de ahorros.

Al fin y al cabo, aún puedo disfrutar de mis Denon tal y como ya hacía antes, usándolos para tener sonido de calidad en cualquier lugar y a cualquier hora.


Un saludo y gracias por tu interés.
Jesús.
Subir
robinette
#7 por robinette el 01/09/2019
Jesus Rodriguez escribió:
Conectar directamente uno de los Denon (con una clavija stéreo, dado que esa es la entrada que hay que introducirle) y el otro (aquí hay redoble) se sincroniza con el anterior vía bluetooth. Y ese creo que es el quiz de la cuestión: esa sincronizaión vía bluetooth entre ambos implica claramente un delay que no se nota lógicamente para empezar a escuchar música, pero sí cuando lo usas como salida de controlador MIDI.

Efectivamente. Aunque conectaras la interfaz con clavija, al final acabas enviando por bluetooth al otro altavoz. Ahí tienes ese delay.
Y es delay (y no latencia) porque escuchas dos señales; la señal a tiempo real (altavoz con clavija) y después la señal con retraso (altavoz con bluetooth).
La diferencia con la latencia es que con esta solo escuchas una señal... pero con retraso.


Jesus Rodriguez escribió:
¿Se podría probar con dos cables directos a ambos? Pues supongo que sí, la verdad es que eso no lo probé.

Eso es. Cada canal a un altavoz. Como debe de ser en este caso ya que no trasmites a ambos de la misma manera si no.

Ya decía yo que olía raro el asunto. :D

Un saludo... y a disfrutar.
Subir
Australia mod
#8 por Australia el 01/09/2019
Yo estaba también atento a ver si se confirmaba lo del problema incluso al conectar con cable, pues era muy extraño. Aclarado ese punto, veo otro problema
Jesus Rodriguez escribió:
¿Se podría probar con dos cables directos a ambos?
Sí, pero no lo veo yo tan directo. Las entradas de los Envaya son estéreo, pues aparentemente cada uno es estéreo, con 2 altavoces por dispositivo (en realidad tiene 2 activos más uno pasivo - "radiador pasivo"). Cada Envaya está por tanto "esperando" recibir dos señales mono correspondientes a los canales L y R que conforman la señal estéreo y que le llegan por una misma entrada minijack estéreo.
¿Cómo has conectado hasta ahora la 2i4 con el Envaya? ¿Desde la salida de auriculares de la 2i4?
Subir
Jesus Rodriguez
#9 por Jesus Rodriguez el 01/09/2019
Dado el muy mal resultado, la verdad es que ni me planteo usarlos ya. Yo tb me planteaba el problema de que los Endaya implican entrada estéreo.... y las posibles implicaciones de ello al usar dos entradas mono o incluso dos entradas estéreo y dejar que el azar jugara a favor del viento....

...en fin: que ya he pasado demasiado tiempo buscando el problema y es mucho mejor dedicar los Endaya para lo que son y usar un par de monitores de estudio para lo que son.

En las pruebas usé las salidas 1 y 2 del Focusrite hacia un Endaya (que se llevaba la señal completa) y él se encarga de repartirla con el otro vía Bloetooth y la cosa va fatal.

En realidad debí imaginármelo, pero supongo que a veces uno no piensa y pasa lo que pasa.

sea como sea, la realidad empírica manda y conectar salida Focusrite a entrada Endaya stéreo va muy mal y hacer los mismito con un altavoz normalito de PC funciona.

¿Probar a hacerlo de modo independiente? Pues con los monitores ya adquiridos, casi que ya me da igual.

Sigo agradeciendo el interés y la ayuda.
Subir
Hilos similares
Respuesta rápida

Regístrate o para poder postear en este hilo