Problemas Jack - Ardour - Pulseaudio

  • 2
carlosgl
#16 por carlosgl el 07/10/2012
Me corrijo, perdon Pablo... NO HABIA INICIADO JACK

cat. jackdrc me dice:
/usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2

Tambien en el terminal puse: amixer -c1
No me devolvio nada... ni error ni nada... no se que significa...

Como sigo para configurar mi placa?
Subir
carlosgl
#17 por carlosgl el 07/10/2012
Otra cosa, al ir a alsamixer y seleccionar la plata fast track pro, me dice: Este dispositivo de sonido no tiene controles.

La tiro a la basura? jajajaj saludos!
Subir
Pablo_F
#18 por Pablo_F el 07/10/2012
Puedes dar


arecord -l

No todas las tarjetas tienen controles accesibles desde alsamixer. No es problema
Subir
carlosgl
#19 por carlosgl el 07/10/2012
Hola Pablo gracias por responder nuevamente. Puse arecord -l y e resultado fue este:

**** Lista de CAPTURE dispositivos hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: CONEXANT Analog [CONEXANT Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 0: USB Audio [USB Audio]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: Pro [FastTrack Pro], dispositivo 1: USB Audio [USB Audio #1 ]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0

Ahora lo prueba y te cuento si cambio algo... saludos y gracias!
Subir
carlosgl
#20 por carlosgl el 07/10/2012
Volvi a probar y no graba... no se si está seleccionada como entrada principal la placa o estará bajo el volumen de entrada desde algun mixer... pero sigo sin poder grabar.
Alguna otra idea o configuración?
Saludos!
Subir
Pablo_F
#21 por Pablo_F el 07/10/2012
A ver, vamos a intentar lo más básico. Prueba lanzar jack desde la terminal con este comando:

jackd -d alsa -dhw:Pro,0 -C

Después lanza ardour, añade una pista mono, asegúrate (en el mezclador) que su entrada está en "In1", ármala para grabar. Conecta el micro a todas las entradas de la tarjeta. Asegúrate que la señal va al PC, no directa a monitorización. De hecho, no deberías oir nada, ya que el comando de arriba lanza jack en modo "sólo captura". Te entra señal? ¿Ves que se mueve el medidor? Da la salida de "jack_lsp -c".

Si no ves señal, haz la misma prueba con el comando:

jackd -d alsa -dhw:Pro, 1.

Informa de los resultados con cada uno de los comandos.

A ver si sacamos algo en claro...
Subir
carlosgl
#22 por carlosgl el 08/10/2012
Pablo hice todos los inetentos que me pediste, no tuve señal... hay 2 cosas que no entendi:
"Conecta el micro a todas las entradas de la tarjeta" y "Asegúrate que la señal va al PC, no directa a monitorización"... la verdad que no tengo idea de que me pedis con esto...

Haciendo los comandos los resultados fueron estos:

jackd -d alsa -dhw:Pro,0 -C = resultado

Al abrir Ardour me dice esto
[WARNING]: No hay salidas disponibles para Audición - se requiere conexión manual

En el terminal dice lo siguiente:
jackdmp 1.9.8
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2011 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
ALSA lib conf.c:4571:(parse_args) Unknown parameter 1
ALSA lib conf.c:4704:(snd_config_expand) Parse arguments error: No such file or directory
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:Pro,0
control open "hw:Pro,0" (No such file or directory)
ALSA lib conf.c:4571:(parse_args) Unknown parameter 1
ALSA lib conf.c:4704:(snd_config_expand) Parse arguments error: No such file or directory
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:Pro,0
control open "hw:Pro,0" (No such file or directory)
audio_reservation_init
Acquire audio card Audio-1
creating alsa driver ... -|hw:Pro,0|1024|2|48000|0|0|nomon|swmeter|-|32bit
ALSA lib conf.c:4571:(parse_args) Unknown parameter 1
ALSA lib conf.c:4704:(snd_config_expand) Parse arguments error: No such file or directory


jack_lsp -c = resultado

system:capture_1
ardour:Audio 1/in 1
system:capture_2
ardour:master/in 1
ardour:Audio 1/out 1
ardour:master/in 2
ardour:Audio 1/out 2
ardour:master/out 1
ardour:master/out 2
ardour:Audio 1/in 1
system:capture_1
ardour:Audio 1/out 1
ardour:master/in 1
ardour:Audio 1/out 2
ardour:master/in 2


jackd -d alsa -dhw:Pro, 1 = resultado

jackdmp 1.9.8
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2011 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
ALSA lib conf.c:4704:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:Pro,
control open "hw:Pro," (Invalid argument)
ALSA lib conf.c:4704:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:Pro,
control open "hw:Pro," (Invalid argument)
audio_reservation_init
Acquire audio card Audio-1
creating alsa driver ... hw:Pro,|hw:Pro,|1024|2|48000|0|0|nomon|swmeter|-|32bit
ALSA lib conf.c:4704:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:Pro,
control open "hw:Pro," (Invalid argument)
ALSA lib conf.c:4704:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM hw:Pro,
ALSA lib conf.c:4704:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM hw:Pro,
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
Cannot initialize driver
JackServer::Open() failed with -1
Failed to open server

Saludos!
Subir
Pablo_F
#23 por Pablo_F el 08/10/2012
Alguien escribió:
"Conecta el micro a todas las entradas de la tarjeta" y "Asegúrate que la señal va al PC, no directa a monitorización"... la verdad que no tengo idea de que me pedis con esto...


No tengo esa tarjeta y estoy intentando adivinar, de ahí las pruebas que te propongo. Estoy mirando las imágenes y el manual de instrucciones de la m-audio fast track pro.

Veo que tiene dos entradas analógicas y una spdif. Supongo que hw:Pro,0 será el par de entradas analógicas y hw:Pro,1 será la entrada spdif. O bien al revés... Cuando digo "probar en todas las entradas" me refiero a probar a enchufar el micro o instrumento a las dos entradas analógicas.

Ahora veo que el potenciómetro de Mix sólo sirve para la monitorización. De todas formas, llévalo a PB para que no te despiste el sonido de la propia entrada. Como jack está en "sólo captura" no deberías escuchar nada. sin embargo, la señal debería ir al ordenador y lo verás en el medidor de ardour si el potenciómetro de ganancia lo tienes bien y ves el led verde encendido. Espero.

A ver, en el segundo comando te dejaste el "-C" del final y además creo que pusiste espacio después de la coma en "hw:Pro,1". Inténtalo otra vez con la sintaxis correcta.

Por supuesto, antes de lanzar el segundo comando, debes interrumpir el primero. Usa Ctrl-C para interrumpirlo.

A ver, ya contarás...
Subir
Elías
#24 por Elías el 18/01/2019
Hola buenas. El romance entre Jack y Ardour se resiste. A ver si conseguimos que se hablen.

Estoy perdido con JACK Y ARDOUR. No llega señal a la pista de Ardour, aunque sí llega perfectamente a la tarjeta de sonido Alesis io2 que utilizo.
Mi SO es Ubuntustudio 16.04.5 LTS

Los controles de alsamixer son estos
┌────────────────────────────── AlsaMixer v1.1.0 ──────────────────────────────┐
│ Tarjeta: HDA Intel F1: Ayuda │
│ Chip: Conexant CX20561 (Hermosa) F2: Información del sistema │
│ Vista: Reproducir F6: Seleccione una tarjeta de sonido │
│ Elemento: Master [Ganancia en dB: -2,00Esc: Salir │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ ├──┤ ├──┤ ├──┤ └──┘ └──┘ ┌──┐ ├──┤ Enabled │
│ │OO│ │OO│ │MM│ │MM│ │OO│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 93 100<>100 100<>100 99<>99 100<>100 100 │
│ < Master >Headphon Speaker PCM Mic Boos S/PDIF Beep Auto-Mut



Y estas son las conexiones de jack con una pista cargada a la que he llamado "Audio001" (era Audio, pero la he renombrado Audio001 para distinguirla mejor)
23:27:57.151 Cambios en las conexiones JACK.
Thu Jan 17 23:27:57 2019: Disconnecting 'system:capture_1' from 'ardour:LTC-in'
Thu Jan 17 23:27:57 2019: Connecting 'system:capture_1' to 'ardour:LTC-in'
Thu Jan 17 23:27:57 2019: Connecting 'ardour:auditioner/audio_out 1' to 'system:playback_1'
Thu Jan 17 23:27:57 2019: Connecting 'ardour:auditioner/audio_out 2' to 'system:playback_2'
Thu Jan 17 23:27:57 2019: Connecting 'ardour:Click/audio_out 1' to 'system:playback_1'
Thu Jan 17 23:27:57 2019: Connecting 'ardour:Click/audio_out 2' to 'system:playback_2'
Thu Jan 17 23:27:57 2019: Connecting 'ardour:Master/audio_out 1' to 'system:playback_1'
Thu Jan 17 23:27:57 2019: Connecting 'ardour:Master/audio_out 2' to 'system:playback_2'
Thu Jan 17 23:27:57 2019: ERROR: JackGraphManager::Connect already connected port_src = 15 port_dst = 3
Thu Jan 17 23:27:57 2019: ERROR: JackGraphManager::Connect already connected port_src = 16 port_dst = 4
Thu Jan 17 23:27:57 2019: ERROR: JackGraphManager::Connect already connected port_src = 1 port_dst = 13
Thu Jan 17 23:27:57 2019: ERROR: JackGraphManager::Connect already connected port_src = 29 port_dst = 3
Thu Jan 17 23:27:57 2019: ERROR: JackGraphManager::Connect already connected port_src = 30 port_dst = 4
Thu Jan 17 23:27:57 2019: ERROR: JackGraphManager::Connect already connected port_src = 31 port_dst = 3
Thu Jan 17 23:27:57 2019: ERROR: JackGraphManager::Connect already connected port_src = 32 port_dst = 4
23:31:10.532 Cambió el gráfico de conexiones de JACK.
23:31:10.632 Cambios en las conexiones JACK.
Thu Jan 17 23:31:10 2019: Connecting 'system:capture_1' to 'ardour:Audio/audio_in 1'
Thu Jan 17 23:31:10 2019: Connecting 'ardour:Audio/audio_out 1' to 'ardour:Master/audio_in 1'
Thu Jan 17 23:31:10 2019: Connecting 'ardour:Audio/audio_out 2' to 'ardour:Master/audio_in 2'
Fri Jan 18 00:36:12 2019: port renamed: 'ardour:Audio/audio_in 1' -> 'ardour:Audio 001/audio_in 1'
Fri Jan 18 00:36:12 2019: port renamed: 'ardour:Audio/audio_out 1' -> 'ardour:Audio 001/audio_out 1'
Fri Jan 18 00:36:12 2019: port renamed: 'ardour:Audio/audio_out 2' -> 'ardour:Audio 001/audio_out 2'
00:37:10.318 Cambios en las conexiones JACK.


No sé qué está mal.
Echo de menos que no aparezca en el out de Ardour un Audio/audio_in2
También veo diferente a los modelos que se muestran en algunos hilos del foro el "LTC-in" en el out de Ardour.

Alguien me puede ayudar. Ya no sé qué probar.
Muchas gracias.

Un saludo.
Elías
Subir
Elías
#25 por Elías el 18/01/2019
¡¡¡LO ENCONTRÉ!!!

He conectado Capture 1 y 2 de System a la pista de Ardour en el out, así están conectados los dos USB.

De momento está funcionando. A ver cuando apague y vuelva mañana.

Gracias amigos por toda la información que se puede encontrar por aquí.
Un saludo.
Elías
Subir
Hilos similares
Respuesta rápida

Regístrate o para poder postear en este hilo