Problemas con Jack

panchubi
#1 por panchubi el 11/12/2018
Hola amigos,

Estoy teniendo algunos problemas con Jack.

Trabajo con una Behringer UM2. En principio todo bien pero de vez en cuando se queda el jack pillado, empieza a emitir un zumbido y a lanzar este tipo de mensajes:

16:52:46.910 XRUN callback (256 omitidos)

Al cabo de un rato para y puedo seguir trabajando normal.

Os adjunto foto de la configuración de jack a ver si me dais alguna idea.

Gracias
Archivos adjuntos ( para descargar)
configuración jack.png
Subir
udog
#2 por udog el 12/12/2018
A mi me ocurre eso cuando tengo el buffer bajo, subiéndolo lo soluciono.
Aunque en la captura que muestras no veo la palabra "buffer", pincha en "parametros" y donde ponga "buffer" subes el valor. Por ejemplo, cuando grabo lo tengo en "2", al mínimo, pero cuando ya estoy mezclando y lo tengo todo cargadito de plugins lo tengo que subir (a 3 o 4) porque si no me aparecen esos mensajes de XRUN (con sus cpnsiguientes cortes) ya que mi máquina no da más de si.
Si puedes sube la captura de la ventana "parámetros" para comprobar que es eso.
Subir
Pablo_F
#3 por Pablo_F el 12/12/2018
Igual tienes configurada una latencia muy baja. Mira en parámetros, como dice udog.
De todas formas, ¿has probado en otros puertos USB? Porque a veces pasa eso,
que hay algún puerto donde funciona mucho mejor que en otros.
Subir
vud1
#4 por vud1 el 20/12/2018
Basicamente los XRUN es que tu máquina no tiene suficiente chichca para darte toda la inmediatez que le estás solicitando. Es decir, estás intentando trabajar con una latencia demasiado baja y la máquina no da a basto.

Ten en cuenta también que los otros programas que tengas abiertos influyen en tu CPU. Si estás petado del CPU al usar Jack, no intentes tener chorromil programas abiertos... cuanta menos programas abiertos (y más CPU libre), mejor.

Opciones?

a) Tener más y mejor hardware... (descartamos)
b) Jugar con parámetros en el qjackctl y sacrificar latencia a cambio de un menor consumo de CPU. Las opciones que podemos tocar son:

- Tamaño del buffer (frames/period): Cuanto menor sea este valor, menos latencia, pero también mayor consumo de CPU. Puedes subirlo un poco hasta que veas que el CPU disminuye. Aquí ver hasta donde es asumible la latencia... yo soy muy maniático con esto y creo que una latencia de más de 10ms me empieza a chinar bastante.

- El sample rate. Lo normal es que vaya a 44.1 Kh, que es la frecuencia de los Cds. He visto por ahí que la gente usa a veces tb 48 y he leido que algunas interfaces de sonido funcionan mejor a unas frecuencias que otras. Cuanto más alto es este valor menor va a ser la latencia pero mayor el consumo de CPU (y nuevamente más XRUNS). Como no controlo mucho este parámetro... yo lo suelo dejar a 44,1

- Periods/Buffer. Si tu interfaz de audio es USB, recomiendan poner su valor al 3. En otro caso, poner al 2.

Vete jugando con estos valores y sacrificando latencia hasta que los Xrun desaparezcan. Además... cierra todos los programas que no estés usando (paquetes ofimatica, navegadores web, etc...) que te puedan estar comiendo CPU. Es bueno lanzar un "top" para ver que procesos están corriendo y dejar sólo los imprescindibles para la producción musical.

SLdss.
Subir
Hilos similares
Respuesta rápida

Regístrate o para poder postear en este hilo