Hackintosh

#1621 por Ed_Saxman el 08/12/2011
El_Atalaya escribió:
Ya he hecho la instalación en mi AMD :)


Cojonudo, El_Atalaya!

Detalla los componentes del equipo, mejor si lo pudieras hacer desde windows con el Aida64 (antes Everest)

¿Qué gráfica tienes?

Dinos también los kexts que tienes en la carpeta /Extra y mira qué bootloader te está metiendo el MyHack ese.

Te recomendaría que lo hicieras a mano, en cualquier caso, es más limpio que usando un postinstalador que no sabes lo que hace.

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#1622 por León_KLS el 08/12/2011
Buenas Ed.

Te detallo los componentes (páginas atrás creo que estaban :P)

Mobo: Gigabyte Ga-MA770T-UD3
CPU: AMD Athlon II x3 445
RAM: 2x2Gb Gskill NQ DDR3 1333
Gráfica: Point Of View GeForce 8400GS 512Mb
HDD: WD Caviar Blue Sata 2 500Gb 7200rpm
HDD2: WD Caviar Black Sata 2 250Gb 7200rpm
HDD3: (externo) Seagate 80Gb IDE

El CD de EmpireEfi usa el Chameleon v2 RC3 para iniciar (es lo que pone) pero sin el CD es el RC5 el que instala...

He probado a instalar los Chameleon desde el RC2 hasta el RC5 diferentes versiones y con todas, se reinicia el PC... Excepto ahora que da un Kernel Panic.. y al iniciar desde el disco, todo perfecto..

En cuanto a la gráfica, en los adjuntos dejo una foto (que no se porque no me deja hacer los pantallazos con la combinación de teclas.. =[ )

Saludos!

PD: Haciendo un update a la 10.6.8 es posible que reconozca la gráfica? (leído en tonymac y en osx86.es...)
Archivos adjuntos:
08122011390.jpg
BBCode:

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
#1623 por Ed_Saxman el 08/12/2011
Bueno... además del bootloader tendrás que editar el org.chameleon.Boot.plist (puede llamarse com.apple.boot.plist también según la versión de chameleon)

Para la gráfica tendrías que añadir

GraphicsEnabler
Yes
(Con el formato de Strings, aqui no se puede ver, en hispa)

Lo de los reinicios, kernel panic y demás, se deberá a que necesitas un kext para anular el powermanagement (nullCPUPowerManagement)

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#1624 por León_KLS el 08/12/2011
Gracias Ed por la respuesta. Dónde se encuentra el plist ese? A mi me sale el apple.boot.plist sin lo del org.

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
#1625 por Ed_Saxman el 08/12/2011
El_Atalaya escribió:
Dónde se encuentra el plist ese?


Está en /Extra, o debería estar. Si no, lo creas, o lo copias de por ahi.

El_Atalaya escribió:
A mi me sale el apple.boot.plist sin lo del org.


Da igual, es por la versión de chameleon. A partir de cierta versión quieren que se llame org.chameleon. en vez de lo otro.

He editado el post de arriba añadiendo lo del nullCPU.

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#1626 por León_KLS el 08/12/2011
#1625 Ok, era el que me imaginaba, solo q en lugar de org. pone com.apple... y al abrirlo en el terminal no me sale el mismo que si lo abro con el TextEditor.. y con este último no me deja guardarlo por no tener "permiso"... :(

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
#1627 por Ed_Saxman el 08/12/2011
Otra opción divertida es el destripe.

Coges el mKextTool y procedes a abrir en canal al EmpireEfi ese para ver qué lleva dentro: http://www.hispasonic.com/foros/hackintosh/278683/pagina67#post2813245

El_Atalaya escribió:
con este último no me deja guardarlo por no tener "permiso"...


Lo copias al escritorio, lo editas, y luego sobreescribes autenticando cuando lo requiera.

EDITO:

Otra cosa fundamental en tu caso es el Kernel. Necesitas cambiarlo por uno parcheado que soporte AMD. El kernel está en la raiz, pero oculto. Puedes dejar el original, meter el parcheado, y especificar en el archivo de antes su nombre para que use el parcheado.

Con la String:

Kernel
Nombre_de_Kernel

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#1628 por León_KLS el 08/12/2011
Probando lo de la copia y edición, si no, procedo a la sala de operaciones para destripar el EmpireEfi jeje

En cuanto al Kernel, ya tengo el Legacy y "en teoria" carga este en lugar del mach_kernel (que leí que tenia que copiar el mach_kernel del Efi pero no se donde..

Gracias y disculpa ser tan pesado.. TT

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
#1629 por Ed_Saxman el 08/12/2011
Lo copias a la raiz, pero debes reparar permisos correctamente al hacerlo, y reconstruir cachés. Puedes pasar el KextUtility de cVad.

Ahora te paso por privado un Link al último kernel AMD para 10.6.8, del 15 de Noviembre 2011.


Edito:

Te dejo unos links que te serán de utilidad:

http://www.insanelymac.com/forum/index.php?showtopic=227592

http://www.insanelymac.com/forum/index.php?showtopic=225717

http://www.insanelymac.com/forum/index.php?showtopic=253767

http://www.insanelymac.com/forum/index.php?showtopic=181876

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#1630 por León_KLS el 08/12/2011
Esto es lo que más me gusta... cuando todo va perfecto y de repente.. te aparece esta pantallita y no inicia de ninguna forma.. TT
Archivos adjuntos:
08122011391.jpg
BBCode:

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
#1631 por Ed_Saxman el 08/12/2011
La mayoría de gente ve esa pantalla mucho antes de lo que lo has hecho tu.

Igual te iria bien reinstalar de 0 como lo has hecho, y seguir a partir de ahí con alguno de los tutoriales (o con una mezcla de todos ellos, ya que he visto que hacen cosas innecesarias en alguno, como meter las cosas en la partición EFI)

Como primer intento has llegado bastante lejos, en cualquier caso. Enhorabuena.

La instalación en AMD es más difícil (o mas en concreto, la postinstalación), y de momento limitada a Snow Leopard, hasta que aparezca algún legacy kernel para Lion.
Hay muchas cosas específicas, y el proceso es bastante distinto al de los procesadores Intel.

Ánimo, e informa de tus progresos!

Workstations Hackintosh en AppleOSX86.com
No respondo dudas por privado. Utiliza los foros.

Subir
#1632 por León_KLS el 08/12/2011
Gracias por los ánimos Ed.
De momento, intentando reinstalar pero lo único que consigo ver es el Kernel_Panic ese al iniciar desde el Empire...
Al iniciar el BootCD con -v -x me sale un:
"Kext es.osx86.driver.Ev0reboot failed to load (0xdc00800e).
panic.... unable to find driver for this platform: \"ACPI\"....]

Os mantendré informados :)

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
#1633 por León_KLS el 08/12/2011
Nuevo intento.. ahora sé lo del KP a que se debe.. Acordaros de cambiar al CD de SL para poder instalar..
Erratas de principiantes + nervios.. = fracaso.. jaja

Saludos musicales compañeros!

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
#1634 por León_KLS el 08/12/2011
Todo perfecto (me refiero igual que antes), ahora a buscar los kexts adecuados para hacer funcionar el bootloader y la gráfica.. La Interfaz de sonido (Lexicon Lambda) funcionando perfectamente... =)

Seguiré informando :D

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
#1635 por León_KLS el 08/12/2011
Conseguido!! :D

Ahora ya el bootloader me va sin el CD!

Pasos:
1- Una vez instalado, ejecutar el MyHack 2.0 RC4 y seleccionar Chameleon + Extra
2- Instalar Chameleon en "\"
3- Cuando pida lo de Extra darle a My own Extra o algo así que dice y darle a OK.
4- Te pedirá que selecciones la carpeta "Extra" (que yo he extraído del Empire_Efi que usaba como bootCD, del Preboot.dmg). Damos a Ok, reiniciamos y.. voilà! Todo perfecto..!

PD: primera vez que me sale la manzanita y la ruedecita en SL jeje
PD1: ahora en Acerca de este Mac me pone 4,2Ghz Core 2 Solo y Memoria 1Gb 800.. (antes me ponia 2Duo y 1333 RAM.. TT)
PD2: Ahora a hacer funcionar el QE
Saludos!

http://www.twitter.com/Leon_kls
http://www.instagram.com/Leon_KLS
https://www.facebook.com/LeonRCS

http://www.kinglionstudio.com

Subir
Respuesta rápida

Regístrate o para poder postear en este hilo