Cómo controlar las salidas midi del logic?

  • 2
#16 por caramuxo el 29/04/2009
En la imagen se ve básicamente cómo tengo configurado mi instrumento externo, en este caso un Proteus 2 (módulo de sonido MIDI). Las conexiones van desde un Photon 25 conectado por USB al ordenador (MIDI IN), desde el puerto de salida MIDI (el Photon tiene un puerto MIDI estándar) conecto al puerto MIDI IN del Proteus. Al go normalito vamos, nada del otro mundo. Eso sí, el Proteus para poder recibir bien y correctamente por todos los canales del secuenciador tiene que estar en modo multi (el Proteus). No sé si tu Yamaha tiene diferentes formas de recibir y enviar MIDI, ni cuantos canales midi tiene, eso deberías de verlo en el manual. Bueno, pues estas son las conexiones físicas. Ahora te explico las del Entorno y la ventana Organizar:
1.- Abrir Entorno (Cmd+8), crear un Multiinstrumento (Nuevo > Multinstrumento) y nombralo como Yamaha. (Importante no tirar ningún cable desde el Multinstrumento). Marcar todos los canales por los que pueda recibir tu Yamaha (me imagino que recibirá por los 16). Con todo el multinstrumento seleccionado (haciendo click en el icono Conector MIDI de encima del objeto) vamos al inspector y en donde dice puerto marcamos el puerto MIDI de salida del secuenciador (en mi caso es el del Photon, pero verás que pone sin nombre porque Logic lo reconoce así). Canales marcas Todos y el resto no las marques. Multinstrumento del Entorno configurado.

2. Crea una pista de instrumento, y en ella cargas el instrumento External Instrument. Entonces se abre una ventana similar a la que en la foto pone Extrenal Instrument. En MIDI destintion escoges "Yamaha: Todos los canales MIDI". En input escoge las entradas de audio de tu interfaz a las que tengas conectado el teclado.

3. En la ventana organizar crea una nueva pista, pero esta vez de MIDI Externo. Ve a la pestaña Biblioteca de Multimedia. Ahí tiene que aparecer una carpeta que se llame Yamaha. Entra en ella y selecciona uno de los canales. En mi caso verás que tengo Proteus 2 1, donde Proteus 2 es el nombre del Multinstrumento y 1 el el número de canal. En este punto , si seleccionas en vez de un canal la carpeta, te enviará el midi a todos los canales del multinstrumento, provocando que suenen cosas que tú no quieres que suenen.

Desde ese momento ya deberías tener tu teclado listo para tocar. Creo que sobra decir que si quieres grabar otra pista por otro canal sólo tienes que crear una nueva pista de MIDI externo y asignarle el canal que desees.
Archivos adjuntos:
Imagen 4.png
BBCode:
Subir
#17 por Blitxea el 29/04/2009
Genial, te debemos un favor. Siento no haberte contestado antes dándote las gracias, pero lo fui dejando... no tengo perdón. Muchas gracias por tus respuestas, un saludo!
Subir
#18 por caramuxo el 29/04/2009
Se os solucionó ya el problema? Me podéis decir qué era lo que teníais mal configurado? Yo me imagino que tendrías creada una Pista en la ventana organizar que en vez de enviar a un sólo canal enviaba en MIDI a todos los canales, pero no sé. Me gustaría que dijerais qué es lo que fallaba. Un saludo.
Subir
#19 por Blitxea el 29/04/2009
Pues ahora mismo no puedo decir qué es lo que fallaba, porque no tengo el Clavia en casa. Cuando lo tenga, probaré. Gracias!
Subir
#20 por belz3 el 30/04/2009
Pues con lo mio no hay manera... me estoy empezando a cansar ya de probar una y otra vez la misma operacion y nada... Realimentaciones, exactamente lo mismo de siempre, he probado varias configuraciones y nada, se que tampoco debe ser tan dificil, pero que no hay manera de configurarlo todo, me suena todo muy mal, con flangers (producidos por las realimentaciones claro esta) y entrandome todo por el mismo canal.

Cuando he creado el mltiinstrumento y creo la pista de External instrument, todo bien hecho, como me dijiste, y despues creo la pista MIDI, y voy a la biblioteca y me aparecen varias carpetas una con el multiinstrumento y sus canales dentro, y despues me aparecen 8 carpetas mas que pone Yamaha MO6 MIDI port 1, y asi sucesivamente hasta el MIDI port 8, con 16 cnales cada una.

Tiene esto algo que ver con las entradas MIDI que tiene mi Yamaha?

Espero que tenga algo que ver, Saludos!!
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo