Configurar Logic X y Roland Aria TR-8

Kevin
#1 por Kevin el 25/10/2014
Hola a todos! Soy nuevo en este foro y me veo obligado a entrar para poder solucionar un problema bastante serio para mi, espero poder tener vuestra ayuda.

En primer lugar decir que hace cuestión de 4 días compré mi roland aira tr 8 y estoy intento configurarla con mi sequenciador que en este caso es Logic X.

Me gustaría si alguien supiese paso por paso lo que hay que hacer desde cero. De todas formas yo voy a explicar lo que estoy haciendo y a ver que tal.

paso 1 - conecto Roland Aira via USB a mi ordenador (IMAC con sistema operativo Mavericks)

Paso 2 - Me voy a configuración de audio y midi de mi mac y lo que hago es crear un dispositivo agregado donde en primer lugar selecciono Focusrite Saffire pro 24 (mi tarjeta de sonido) y a continuación Roland TR8

paso 3 - Abro logic X - preferencias - Dispositivo de Entrada : Roland tr8 y dispositivo de salida: Saffire focusrite

justo debajo de entrada y salida hay cuatro casillas para marcar, yo marco solo las 2 primeras.

Paso 4 - preferencias - Midi - Sincronizar- Activo la casilla de Reloj Midi.

Paso 5 . Abrir canal - Audio - Entrada 3 - Salida Output 1-2 - Marco Casilla de 'Monitorización de entrada' - Numero de pistas: 11 - CREAR.

Una vez hechos estos pasos yo le doy al play, y suena todo sin problema.

los problemas son: 1 que no se cuadrar con el proyecto, es decir yo pongo la claqueta de Logic X y va siempre descuadrado y luego para grabar si yo le al doy al botón de grabar, aparece una linea roja de grabación pero no graba nada porque la TR8 no se activa, pero si yo le doy al play para activar Roland y a continuación le doy a grabar, si graba pero empieza a grabar donde le da la gana total que al final, lo mismo empieza descuadrado.


Espero que me podáis ayudar a que mi roland no se quede como un precioso pisapapeles!

Muchas gracias!
Subir
Jordi Torres mod
#2 por Jordi Torres el 25/10/2014
Hola,

Kevin escribió:
Paso 2 - Me voy a configuración de audio y midi de mi mac y lo que hago es crear un dispositivo agregado donde en primer lugar selecciono Focusrite Saffire pro 24 (mi tarjeta de sonido) y a continuación Roland TR8


Yo me saltaría este paso a menos que necesites poder grabar simultáneamente las entradas de tu focusrite y el audio que venga de la TR-8. Nunca he tenido una focusrite, pero lo del dispositivo agregado no se lleva bien con algunas interfaces.

Kevin escribió:
paso 3 - Abro logic X - preferencias - Dispositivo de Entrada : Roland tr8 y dispositivo de salida: Saffire focusrite


Perfecto, haciéndolo así definitivamente no necesitas el dispositivo agregado.

Kevin escribió:
justo debajo de entrada y salida hay cuatro casillas para marcar, yo marco solo las 2 primeras.


OK.

Kevin escribió:
Paso 4 - preferencias - Midi - Sincronizar- Activo la casilla de Reloj Midi.


Tienes que elegir un puerto (el de la Roland o simplemente "Todos") por donde enviar Reloj MIDI, pero supongo que simplemente se te olvidó comentarlo.

Kevin escribió:
Paso 5 . Abrir canal - Audio - Entrada 3 - Salida Output 1-2 - Marco Casilla de 'Monitorización de entrada' - Numero de pistas: 11 - CREAR.


Bien, hay que empezar por la entrada 3 ya que la 1 y 2 son la suma de todas las salidas. Tienes que marcar la opción "ascendente" en el menú de entradas si quieres que cada pista que se cree tenga la entrada adecuada. Supongo que también lo habrás hecho pero no lo comentaste.

Kevin escribió:
1 que no se cuadrar con el proyecto, es decir yo pongo la claqueta de Logic X y va siempre descuadrado


Probablemente tengas que ajustar la transmisión de reloj MIDI. Esto lo haces desde los ajustes (no preferencias) de sincronización MIDI del proyecto.

Kevin escribió:
pero no graba nada porque la TR8 no se activa


Debería activarse en el compás 1 1 1 1, que es donde Logic el mensaje MIDI Start.

Saludos,

J.
Subir
Kevin
#3 por Kevin el 27/10/2014
Muchísimas gracias! en cuanto a la grabación hay una opción que es Archivo > Ajuste de proyecto > Audio > Y ahí quitas la opción Pre-Roll de Reproducción.

Y ya se graba bien ahora es el problema con que se des-cuadra un poco.... seguiré investigando....


Saludos
Subir
Jordi Torres mod
#4 por Jordi Torres el 27/10/2014
Kevin escribió:
Muchísimas gracias! en cuanto a la grabación hay una opción que es Archivo > Ajuste de proyecto > Audio > Y ahí quitas la opción Pre-Roll de Reproducción.


Cierto, me había olvidado de ese detalle:

https://www.hispasonic.com/foros/logic-9-electribe-em-1-midi-clock-ayuda/380733#post3037404

Kevin escribió:
Y ya se graba bien ahora es el problema con que se des-cuadra un poco.... seguiré investigando....


Puedes intentar compensar con lo que mencioné antes:

Jordi Torres escribió:
Probablemente tengas que ajustar la transmisión de reloj MIDI. Esto lo haces desde los ajustes (no preferencias) de sincronización MIDI del proyecto.


Aunque ten en cuenta que siempre habrá algo de jitter al sincronizar con reloj MIDI, nunca sonará exactamente igual dos veces.

Si los resultados te son intolerables, siempre puedes tomar medidas con Flex Time:

https://www.hispasonic.com/foros/retardo-grabacion-sincronizacion-logic-9-ympc2000xl/459511/pagina2#post3851380

Saludos,

J.
Subir
jesus_nevado
#5 por jesus_nevado el 28/10/2014
kevin tienes que poner en ajustes de proyecto/audio la frecuencia de muestreo a 96khz ya que la tr-8 trabaja unica y exclusivamente a esa frecuencia y si no realizas ese ajuste se producen descuadres de audio. En preferencias activa la grabacion a 24 bits también.
Activa tambien el modo de baja latencia si ves que persisten los problemas

Un saludo
Subir
Alvaret
#6 por Alvaret el 23/10/2016
Buenas tardes gente;

Veo que el post es de hace tiempo pero a ver si me podéis echar un cable por favor.

Estoy empezando con este mundo de la producción y Tengo la TR8 , teclado M-Audio Oxygen 49 y como tarjeta de audio una Native Audio 8.

Tengo 1 problema:

1º. Sigo todos los pasos que hizo Kevin en su día pero no hay manera de que me reconozca el sonido de la TR8. La tengo conectada por USB al Mac, los monitores conectados en la salida 1/2 de la Audio 8, selecciono Roland TR8 como dispositivo de entrada y dispositivo de salida la Audio 8 y nada de nada. Incluso he creado un dispositivo agregado donde en primer lugar selecciono la Audio 8 y a continuación Roland TR8. Puede ser por la tarjeta de audio??

Muchas gracias por vuestra ayuda y comprensión.
Subir
Jordi Torres mod
#7 por Jordi Torres el 23/10/2016
#6 Hola,

La TR-8 funciona a una frecuencia de muestreo de 96kHz. Como esto no se puede cambiar, te obliga a poner tu proyecto de Logic a la misma frecuencia de muestreo. Lo mismo para cualquier otro dispositivo (tu Audio 8), pero eso ya debería ajustarse automáticamente al hacer el cambio de frecuencia de muestreo en los ajustes del proyecto.

No se si será la solución a tu problema, peo es lo primero que tienes que mirar.

Saludos,

J.
Subir
Alvaret
#8 por Alvaret el 23/10/2016
#7 La frecuencia la he puesto a 96kHz y nada de nada. Creo el proyecto como audio, es correcto no?
Subir
Jordi Torres mod
#9 por Jordi Torres el 23/10/2016
Hola,

La verdad que no sé a qué te refieres con lo de crear el proyecto "como audio".

Lo importante es que la frecuencia de muestreo del proyecto coincida con la del cacharro. La frecuencia de muestreo del proyecto la especificas en los ajustes de audio del proyecto (Menú Archivo > Ajustes del Proyecto > Audio...).

Con esto y luego de haber puesto la TR-8 como dispositivo de entrada en las preferencias de Logic, deberías poder recibir audio de la TR-8.

Ya de paso ve a la pestaña "General" de las preferencias de Audio de Logic, y asegúrate que la "monitorización software" esté activada, y la preferencia "Monitorización solo en pista activa y en las activadas para grabación" desactivada.

Saludos,

J.
Subir
Alvaret
#10 por Alvaret el 01/11/2016
#9 Por fin veo algo de luz al final del túnel :-)

Ahora ya consigo sacar algo de sonido pero solo suenan el BASS DRUM y SNARE DRUM, los demás veo que los reconoce pero no suenan. Que puede ser??

Gracias por vuestra ayuda.
Subir
Jordi Torres mod
#11 por Jordi Torres el 02/11/2016
#10 Para tener acceso a los sonidos individuales tienes que elegir las entradas 3 en adelante. Aparte de eso no parece que haya que hacer nada especial:

https://www.rolandus.com/support/knowledge_base/201920269

Solo como prueba, si eliges solamente las entradas 1 y 2 en una pista estéreo...puedes oir todo o solo bombo y caja?

Saludos,

J.
Subir
Alvaret
#12 por Alvaret el 27/11/2016
Jordi Torres escribió:
Solo como prueba, si eliges solamente las entradas 1 y 2 en una pista estéreo...puedes oir todo o solo bombo y caja?


Si quiero escucharlo todo por separado tengo que crear un proyecto con 13 pistas y escoger la "Entrada 1". El BASS DRUM empieza a partir de la pista 3 y así cada sonido en adelante. Las pistas 1 y 2 puede ser que hagan de master o algo? Porque si elijo la entrada 1 y 11 pistas como tiene la TR8 las 2 ultimas suenan en la 1 y 2.
http://thumbs.subefotos.com/1ca6ef5fb1d24aaea9d40dea93fcb24fo.jpg

Gracias por tu atención Jordi.
Subir
Álvaro Albarrán
#13 por Álvaro Albarrán el 01/08/2018
Hola, me uno al hilo aunque hace tiempo que no veo actividad por aquí..

Me trae de cabeza la sincronización de la TR8 a la hora de grabar en mis proyectos.. he seguido paso a paso las indicaciones del enlace que muestra Jordi en Roland donde vas creando las 11 pistas.. hasta ahí todo bien y a mí sí me suenan los instrumentos, lo único que es como si lo escuchara por un lado con la web app de MOTU (trabajo con la UltraLite Mk4) donde tengo activadas las dos entradas donde está conectada la TR8. Adjunto captura de pantalla. Como bien se ve las tengo muteadas porque a la hora de grabar en el proyecto se escuchan como dos señales y con retardo, y es un poco caos.. dejando estas entradas (Analog 1 y Analog 2) activas escucho los ritmos que creo en la TR perfectamente sin latencia, el problema viene cuando en el proyecto empiezo a grabar con los ritmos que ya he creado.. no hay manera de sincronizarlos perfectamente.. ni de escucharlos en tiempo real sincronizados como hago por el mixer de la web app de MOTU.. hasta probé a quitar el compás de entrada porque dejando un compás de tiempo antes de la grabación la TR no arranca automáticamente a tempo..espero explicarme bien.. lo de canción SPP al inicio de la reproducción y en el salto de ciclo lo tengo en ese modo porque cuando llega al principio del ciclo sigue sincronizada a tempo (sin grabar) por eso lo tengo así, de las otras formas se me desincroniza el ritmo... adjunto algunas capturas más de la configuración que tengo en Logic. Muchísimas gracias por la ayuda. Alguna idea? Espero vuestras respuestas..

PD: La frecuencia de muestreo me marca la tarjeta de sonido 44'1 Khz, tengo asi configurado el proyecto puesto que al probar a ponerlo a 96 Khz como explicáis por la TR mi Mac me dijo que por aquí.. no podía aguantar el ritmo de todo lo que hago produciendo a esa frecuencia de muestreo y se sobrecargaba el sistema a menudo... imposible trabajar a esa frecuencia de muestreo en mi ordenador.. como véis trabajo con el tamaño del búfer al máximo para que vaya lo más desahogado posible..
Archivos adjuntos ( para descargar)
Captura de pantalla 2018-08-01 a las 7.44.41.png
Captura de pantalla 2018-08-01 a las 7.49.08.png
Captura de pantalla 2018-08-01 a las 7.49.21.png
Captura de pantalla 2018-08-01 a las 7.48.33.png
Subir
Jordi Torres mod
#14 por Jordi Torres el 07/08/2018
Hola,

Álvaro Albarrán escribió:
lo único que es como si lo escuchara por un lado con la web app de MOTU (trabajo con la UltraLite Mk4) donde tengo activadas las dos entradas donde está conectada la TR8. Adjunto captura de pantalla. Como bien se ve las tengo muteadas porque a la hora de grabar en el proyecto se escuchan como dos señales y con retardo, y es un poco caos.


Esto quiere decir que estás monitoreando a través de Logic (monitorización software) y directamente a través de tu MOTU (monitorización "hardware" o "directa") a la vez. Tienes que elegir una de las dos. De hecho en tus imágenes se ve como tienes la TR-8 como dispositivo de entrada (audio por USB directamente desde la TR-8) y además has conectado las salidas de la TR-8 a las entradas de la MOTU. Eso nunca va a sonar bien simultáneamente.

Álvaro Albarrán escribió:
PD: La frecuencia de muestreo me marca la tarjeta de sonido 44'1 Khz, tengo asi configurado el proyecto puesto que al probar a ponerlo a 96 Khz como explicáis por la TR mi Mac me dijo que por aquí.. no podía aguantar el ritmo de todo lo que hago produciendo a esa frecuencia de muestreo y se sobrecargaba el sistema a menudo... imposible trabajar a esa frecuencia de muestreo en mi ordenador.. como véis trabajo con el tamaño del búfer al máximo para que vaya lo más desahogado posible..


Pues es lo que recomienda Roland, 96 kHz, no sé si habrás leído todo el articulo:

https://www.roland.com/us/support/knowledge_base/204280335/

Álvaro Albarrán escribió:
el problema viene cuando en el proyecto empiezo a grabar con los ritmos que ya he creado.. no hay manera de sincronizarlos perfectamente.. ni de escucharlos en tiempo real sincronizados como hago por el mixer de la web app de MOTU.. hasta probé a quitar el compás de entrada porque dejando un compás de tiempo antes de la grabación la TR no arranca automáticamente a tempo..espero explicarme bien.. lo de canción SPP al inicio de la reproducción y en el salto de ciclo lo tengo en ese modo porque cuando llega al principio del ciclo sigue sincronizada a tempo (sin grabar) por eso lo tengo así, de las otras formas se me desincroniza el ritmo....


Yo no tengo un cacharro de estos así que no puede decirte cuál es la mejor manera de incorporarlo con Logic. Si dices que sincroniza bien al reproducir y no al grabar, quizás haga falta que ajustes el retardo de grabación en Logic.

Un buen tutorial para ver en cuanto al tema de sincronización/latencia en Logic y cómo configurarlo en todo tipo de situaciones es "Logic's Latency Toolbox" de MacProVideo/AskAudio. Aunque se hizo en Logic 9 hace varios años la mayor parte (sino todo) del contenido todavía es válido para Logic Pro X.

Saludos,

J.
Subir
Álvaro Albarrán
#15 por Álvaro Albarrán el 08/08/2018
#14 Muchísimas gracias por responderme Jordi y por aclararme tantas dudas.

Respecto a monitorear por duplicado, ya que dispongo de la webapp de motu y la conecto directamente a la tarjeta de sonido por jack debería optar por esta opción para así ahorrar recursos de CPU y obviar la monitorización por software? Ya que deduzco que tiene latencia? La cuestión es que la tengo conectada por USB para tener configurado el midi clock y poder sincronizar el tempo de la TR-8 con el proyecto. Ahora me falta saber si puedo dejarla conectada por USB y que solo transmita datos midi y el audio lo transmita directamente a la motu por conexión jack. Supongo que entonces debería de poner dispositivo de entrada la MOTU. (Sólo suponiendo).

Respecto a la frecuencia de muestreo, sí es correcto, evidentemente ya sabía que la TR-8 tiene una frecuencia de muestreo a 96Khz, lo único es lo que comentaba.. mi sistema sufría de sobrecarga del motor de audio y se solucionó cuando cambié la frecuencia del proyecto a 44,1Khz, que al finalizar mis trabajos es a la frecuencia que he de exportar los tracks porque me lo piden así los sellos discográficos (.wav 16 bit a 44,1Khz) , aún así muchas gracias por el artículo porque lo he leído y voy a probar a configurar de nuevo todo a 96Khz.

Respecto a la latencia en la grabación, también le echaré un ojo al tutorial que me dices sobre Logic para tratar de solucionarlo todo de una vez..

Muchas gracias otra vez!

PD: Feliz 808-day de Roland!!!

Saludos!

Álvaro Albarrán
Subir
Hilos similares
Respuesta rápida

Regístrate o para poder postear en este hilo