Problema pedal sustain con controlador midi.

  • 1
OptiMuff Prime
#1 por OptiMuff Prime hace 3 semanas
Hola!
No sé si el tema debería de ir en este foro...

Tengo un controlador midi samson carbon 61 con el que llevo años sin problema ninguno.
Hace poco compré un pedal de sustain en thomann (marca propia, un millenium lead foot LFD-10) y no consigo que funcione el efecto sustain.
El pedal podeis verlo AQUÍ.
Adjunto también una imagen:
11619094_800.jpg

Lo tengo conectado al DAW con el instrumento virtual VST KEYZONE (con el que tampoco he tenido ningún problema nunca) y nanay.

Lo raro es que en el DAW llega señal midi cuando pulso el pedal.
El controlador midi también detecta actividad midi cuando pulso el pedal...
Pero nada: Las notas no quedan con sustain cuando lo pulso.
Por si acaso también he probado a cambiarle la polaridad, y nada.
Eso si: Cuando lo tengo en una posición de la polaridad, el controlador midi marca "0", y al pulsar el pedal cambia a "127".
Cuando le cambio la posición, marca "127" y al pulsarlo marca "0".

Todo esto me lleva a pensar que el controlador funciona bien... ¿Qué ocurre entonces?

Se agradecerá muchísimo una ayudica, compis. (y un "me gusta", of course! :birras: )
Subir
Alexmx03
#2 por Alexmx03 hace 3 semanas
Aparentemente, y por lo que describes, el pedal funciona correctamente. Has probado con otro vst? Que daw utilizas?
Subir
1
pablofcid
#3 por pablofcid hace 3 semanas
Comprueba qué número de controlador está generando tu carbon 61 al pulsar el pedal. Tiene que ser el CC 64.
Subir
1
OptiMuff Prime
#4 por OptiMuff Prime hace 3 semanas
Alexmx03 escribió:
Que daw utilizas?

Cubase.
No me ha dado problema con ningún hardware hasta ahora.

pablofcid escribió:
Comprueba qué número de controlador está generando tu carbon 61 al pulsar el pedal. Tiene que ser el CC 64

Exacto, es el cc64...
Por eso me extraña tanto que no funcione. :-k
Subir
kamikase ♕ ♫
#5 por kamikase ♕ ♫ hace 3 semanas
No tendrás activados los filtros MIDI?
Subir
1
OptiMuff Prime
#6 por OptiMuff Prime hace 3 semanas
#5 Hola, Kami!
Pues no tengo la menor idea de qué leñe es eso... :?
Subir
kamikase ♕ ♫
#7 por kamikase ♕ ♫ hace 3 semanas
En configuraciones hay un apartado de filtros MIDI que a veces está preconfigurado.

Revisalo por si está filtrado el pedal.

Un abrazo OptiMuff Prime
Archivos adjuntos ( para descargar)
414658-THRU_preferences.JPG
Subir
1
OptiMuff Prime
#8 por OptiMuff Prime hace 3 semanas
En cuanto llegua a casa lo pruebo...
Si es eso me pondré como unas castañuelas! :birras:
Subir
kamikase ♕ ♫
#9 por kamikase ♕ ♫ hace 3 semanas
Ojala que sea eso OptiMuff Prime.

Saludos!
Y que hayas pasado un buen finde.
Subir
OptiMuff Prime
#10 por OptiMuff Prime hace 3 semanas
Hola!
He probado y nanay...
Lo curioso es que en algunos VST (en muy pocos) sí que funciona el pedal de sustain.
Me resulta rarísimo...
¿Como puede ser?

El controlador midi recibe la información del pedal, sin embargo casi ningún instrumento virtual reacciona...
Yo pensaba que el pedal no hace más que ordenarle al controlador que "dispare" información de que la nota se sostenga, independientemente del instrumento virtual que se use.
¿Estoy diciendo una tontería?

Es una lástima porque de los pianos que tengo, el keyzone es el que más me gusta (ya me gustaría poder tener el steinway en VST :-k ).
Subir
pablofcid
#11 por pablofcid hace 3 semanas
Es bien raro, sí.

Yo usaría un programa de tipo 'MIDI Monitor' para ver exactamente qué está generando tu controlador.
¿Es el único controlador (ya sea hardware o software) que tienes conectado? No vaya a ser que tengas algún otro elemento enviando órdenes de sustain off, o bien alguna de las del grupo de 'all notes off', 'all controllers off', etc.
Pero vaya, si en la misma pista y con los mismos ajustes, según cambias de un plugin a otro funciona o deja de funcionar la acción esperada del control de sustain, la verdad es que no termino de ver claro qué puede suceder.
Subir
1
OptiMuff Prime
#12 por OptiMuff Prime hace 3 semanas
pablofcid escribió:
Yo usaría un programa de tipo 'MIDI Monitor' para ver exactamente qué está generando tu controlador

Lo acabo de instalar. No tengo ni pajolera de estas cosas...
Probé a ejecutarlo sin ningún dispositivo conectado y me decía que no se podía abrir puesto que no había dispositivos MIDI corriendo.
Después conecté mi tarjeta de sonido (roland quad capture), mi controlador midi (samson carbon) y abrí el DAW.
Me sale esto:
Archivos adjuntos ( para descargar)
oiuh.jpg
Subir
OptiMuff Prime
#13 por OptiMuff Prime hace 3 semanas
Antes de ejecutar el DAW, el midi monitor no me daba ningún mensaje de error.
Tras abrir el DAW me dice que no puede monitorizar el dispositivo midi (supongo que es el teclado porque no hay otro) porque "otro programa lo está utilizando").

pablofcid escribió:
¿Es el único controlador (ya sea hardware o software) que tienes conectado?

Sí, es el único.
A no ser que la tarjeta de sonido (que tiene entrada y salida midi) se considere un controlador.

No sé exactamente qué tengo que hacer en el "midi monitor" para que me salga un listado.
Imagino que al tener tan pocos aparatos midi solo sale esa pantalla, pero es que no tengo ni pajolera de midi. :?

No sé si aporta algo, pero cuando piso el pedal, en la pantallita dle controlador midi (samson carbon) siempre pasan los números de cero a 127.
Da igual el VST que tenga cargado, siempre cambian al ser pulsados, lo cual creo que corrobora que el pedal de sustain funciona perfectamente...

PD: ¡Graciñas por estar ahí, Pablo!
Subir
kamikase ♕ ♫
#14 por kamikase ♕ ♫ hace 3 semanas
Prueba a configurar que el instrumento virtual reconozca el pedal.
Muchas veces el VST está configurado para ser disparado sólo con las teclas y no reconoce nada más.

Mira en los eventos grabados si el pedal de sustain graba señal.
Si aparece enviando datos entonces es el vst mal configurado.
Me pasa con algunos VST que tengo que configurar de forma manual moduladores y otros datos MIDI.

Saludos.
Subir
1
OptiMuff Prime
#15 por OptiMuff Prime hace 3 semanas
kamikase ♕ ♫ escribió:
Si aparece enviando datos entonces es el vst mal configurado

El cubase me indica que recibe midi cuando piso el pedal... ](*,)
Lo que no sé es como se configura el VST, porque no aparece por ningún lado nada relacionado con el pedal de sustain.
De hecho no he visto ningún lugar donde configurar este parámetro en ningún VST.
Hoy he descubierto 3 VST más que sí reconocen el pedal de sustain, pero la mayoría no lo hacen...
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo