¡Cuidado! Downgrade firmware a Mac Pro Mojave para atrás

Juanins
#1 por Juanins el 13/12/2019
Hola,
Abro el hilo sobretodo por buena acción para que nadie la cague como yo. Si alguien ayuda genial, aunque no es fácil. Sino, cuando me entere de cómo solucionarlo lo contaré porque en español no encuentro nada y en inglés casi que tampoco.
Quería doble partición, 1 con mavericks para pro tools 10.3.10 si no recuerdo mal y otra con High Sierra o Mojave para Final Cut Pro X 10.4.7.
La Rme fireface 800 tiró en los 3 sistemas operativos, cosa que es lo más agradable de todo, que una tarjeta mítica y súper sólida que salió en 2004 creo recordar, rule con un sistema operativo de 2019.
A lo que voy, mi cagada fue que rulando como rulaba el audio en high sierra en vez de quedarme ahí ya quise probar Mojave. Hay en un punto de la instalación en el que una ventana de diálogo te dice que para pasar de high sierra a Mojave requiere un upgrade de firmware del Mac Pro. Se hace fácil:
Apagas. Pulsas encendido sin soltar y cuando empieza a flasear rápidamente y hace un pitido largo y se actualiza.
¿Qué sucedió a partir de aquí? Se instala Mojave de fábula, FCP X 10.4.7 también fetén, súper fluido y digo, venga, vamos a Mavericks. Ups! Pantallazo tras pantallazo.
Dicho esto, sí alguien me echa un cable genial, pero pensad muy muy bien antes de hacer un upgrade de firmware. A mí sin upgrade de firmware me da igual que se me casque un sistema, porque curro en otros discos físicos, guardo todo el soft y si tengo que formatear y plancharlo, no tengo pega, pero el upgrade de firmware cuidado extremo.
Un saludo y gracias de antemano
Subir
powerstudios
#2 por powerstudios el 13/12/2019
Facil solución pero no es un solo disco, además no se si usaras ssd pero a un ssd no es bueno hacerle particiones.
(que lo sepas,) un sistema en un disco y otro sistema en otro, fuera problema, la has liado tu solo, nunca se debe poner un fimware ultimo sin saber las cosas buenas o no tan buenas de antemano! ` si una cosa te funciona bien no la toques` un saludo
Subir
1
powerstudios
#3 por powerstudios el 13/12/2019
Te digo todo esto amigo Juannins porque la única manera de hacer un downgrade de fimware en este caso seria reconstruyendo la boot rom, un trabajo tedioso`, lo que puede que ahora te pase es para que veas incluso el disco de mavericks tengas que sacar el de mojave! meter y sacar segun te convenga`
un saludo
Subir
1
MrBlue
#4 por MrBlue el 14/12/2019
Hola, pues no se, a mi me funciona todo correctamente con el último firmmeware del Mac Pro 5.1 , y también tengo una RME fireface 800 que funciona sin problemas.
Y no se por que a un SSD no se le pueden hacer particiones para instalar 2 SO diferentes, igual la he cagado, pero yo lo tengo así ....
Saludos.
Subir
1
Juanins
#5 por Juanins el 15/12/2019
#3 Muchas gracias, Power! Siempre estás al quite.
Pues mira, la verdad es que ni siquiera puedo arrancar otro sistema operativo y este me arrancan mal. En el momento de estar cargando la línea de progreso con la manzana, salen unos fallos de tarjeta gráfica y luego funde a negro Segundo y medio. Luego parece que va a salir el pantallazo y de pronto vuelve a ponerse la manzanita y la línea de progreso de golpe se llena del todo y carga el sistema operativo.
Empiezo a creer que o se ha cargado mal el firmware o con el nuevo firmware la gráfica se ha tostado.
Mañana lunes se lo llevo a un técnico muy muy pro a qué me diga que coño pasa.

#4 Por lo visto lo que leo es que hay cambios en los sistemas de archivos desde Capitan hasta Sierra, High Sierra, Mojave y Catalina y no son compatibles en el mismo disco. A mí también me pasó algún problema desde Mountain Lion a Yosemite teniendo esas dos particiones en un disco. Diría que hay cambios bestias entre mavericks y yosemite, entre Capitan y Sierra y de firmware entre high sierra y Mojave. Sinceramente ten cuidado, porque según mi experiencia empírica (no tengo ni idea, realmente) si tienes combinaciones de sistemas operativos con esos saltos puede no irte bien. A mí no me ha ido bien y no sólo en esta máquina, ni en un mbp ni en un mp 3.1. Pero mira, si te va, de pm. Casualmente a mí me falló siempre instalando 2 particiones con esos sistemas con “cambio generacional” siempre en Ssd. No he probado en hdd y no lo voy a hacer sencillamente porque ya no instalo en otra cosa que no sea Ssd y además ya voy a tener discos diferentes para particiones. En mi experiencia empírica todo me casa y prefiero evitar problemas.
Yo creo que Power dice que no conviene tener particiones en SSD por eso. Si hay sistemas incompatibles en el mismo disco, la manera de no cagarla si no te acuerdas de cómo era el asunto, será no teniendo 2 sistemas en un único Ssd...
Puede que haya más razones y que de verdad no sea bueno tener 2 arranques en Ssd. No he mirado el google. Sencillamente a mí no me va bien y ya pondré (si puedo) Mavericks en un Ssd junto a la óptica y high sierra por adaptadora a pcie (ahí me dejo los 4 slots libres para datos).
Gracias por colaborar
Un saludo
Subir
Juanins
#6 por Juanins el 15/12/2019
#4
https://www.xataka.com/respuestas/es-razonable-particionar-disco-ssd

Lo primero que leo es esto, pero vamos. No he desarrollado. Aunque es un poco off topic, si desarrollas pues eso que nos llevamos, ya que mi post de momento mala solución tiene...
Subir
wikter @ TheSickbeat
#7 por wikter @ TheSickbeat el 17/12/2019
Te diría que verificases RAM y GPU, es cierto que la RAM tiene muy poco castigo, pero también puede fallar a la larga.
La GPU por descontado es una parte que sufre mucho, sobretodo a partir de Mojave, cuyo interfaz gráfico necesita una gráfica con rendimiento considerable, las viejas 5770 no dan para mover el interfaz gráfico.
Subir
1
Juanins
#8 por Juanins el 17/12/2019
#7 Muchas gracias! Andaba también con esa mosca detrás de la oreja y le he metido otra gráfica también cañera dentro de las “metal” y similar resultado. Eso sí, con esta otra arrancan otros discos con otros sistemas y de hecho afortunadamente coexistiendo dos discos con dos arranques diferentes (no ha llegado a ese punto que decía Power de tenerle perpetuamente que despinchar un disco con un arranque si querías con el otro). Pero sigue teniendo el dichoso apagón a negro durante la carga de la manzana antes del sistema operativo.
Respecto a la ram, creo que eran módulos compatibles bastante nuevos aunque los compré en una app de clasificados a una especie de profesional de este estraperlo y por soft parece ser que la ha leído siempre arrancado el SO... En esta caja 5.1 por leds detrás de uno de los procesadores creo que es imposible verlo (en el 3.1 se veía mejor)
Sospecho que no ha actualizado correctamente el firmware.
Ya he llamado a un servicio técnico especializado en Mac no oficial y me han dicho que hay que echar atrás ese firmware cargándole la efi anterior. Que no es sencillo porque es una máquina con unos años y que tienen que encontrar esa efi. Afortunadamente, si pueden solucionarlo, que cruzo los dedos que sí, me dijo que la factura no iba a ser abultada. Sin embargo otros me
daban un mal rollo importante. Uno que 90€/h (supongo que sin iva) y que serían mínimo hora y media o dos pero que no sabía, otros que solo por diagnosticar 32€ con iva... La sensación que se me queda es que algunos servicios técnicos de Apple dices “pro” y que te dedicas a algo creativo con el ordenador y les hacen los ojos chiribitas porque ya tienen la excusa perfecta para pegarte un sablazo monumental.
Si todo acaba bien, haré una reseña positiva en el sitio al que lo llevé en google y también lo comentaré en el hilo por si alguien de Madrid se ve en alguna similar...
Seguimos por aquí, y agradeceros una vez más a todos la colaboración.
Saludos
Subir
powerstudios
#9 por powerstudios el 24/12/2019
#8 Antes de llevarlo a un servicio tecnico especializado o no ( mucho cuidado con todos, te lo digo yo que me paso todas las semanas arreglando Mac Pros que salen de un supuesto servicio tecnico muy bueno) haría un reset pvram, ¿se lo has echo Juanins? haz una busqueda, es fácil, 4 comandos y ya esta.
Felices fiestas.
Subir
Juanins
#10 por Juanins el 31/12/2019
Le doy un tiento, señor!
Muchas gracias, un abrazo y felices fiestas!!
De momento nada, no han sido capaces de volverlo atrás porque el upgrade de firmware se hizo con una tarjeta flash.
Subir
Responder

Regístrate o para poder postear en este hilo