No sé conectar un teclado MIDI en MAC (M-Audio FastTrackPRO)

#1 por ChoPraTs el 04/06/2008
Hola a todos. Antes de nada perdón por ser un poco cortito... Supongo que hago algo mal, pero no hay forma de conectar un teclado midi a mi tarjeta de sonido.

Tengo un Yamaha P80 (teclado de 88 notas de teclas contrapesadas) un Macbook Pro y hasta ahora lo conectaba por MIDI mediante un convertidor Midi-Usb de Edirol (UM-1EX). Para ello en las Preferencias del Sistema / Audio Midi creé un nuevo dispositivo (siguiendo las instrucciones) y lo conecté tanto virtualmente como físicamente. Todo funcionaba a la perfección. Recibía señal y podía enviar.

Hoy he comprado una M-Audio FastTrakPro, por USB. La idea es tener el teclado conectado a la interfaz externa, pues también tiene lógicamente MIDI IN y MIDI OUT.

Además, tiene dos leds en la parte frontal que indican si está recibiendo señal.

Si reproduzco cualquier cosa en el Mac que sea MIDI, la señal llega perfectamente a la tarjeta, sin embargo no se transmite al teclado (no suena).

Pero lo curioso del caso, es que tampoco pulsando las teclas del piano llega señal a la tarjeta.

He probado reiniciando todo, teclado, tarjeta, ordenador... He creado otro dispositivo en las Preferencias del Sistema / Configuración de Audio / Midi, lo he borrado, he vuelto a crear otro. He vuelto a probar la Edirol, etc.

No sé que pasa. Con la Edirol funciona, pero con la otra no.

¿Qué hago mal? ¿Acaso son incompatibles mi teclado y la interfaz? ¿No se supone que el protocolo MIDI es un estándar?


A ver si alguien me echa un cable. Iba a ponerlo en el hilo de principiantes, pero al ser usuario de MAC supongo que tendré más respuestas aquí.

Gracias.
Subir
#2 por ChoPraTs el 05/06/2008
Creo que voy a devolverla... Lo he probado en Windows, en otro ordenador, con otros cables... Debe ser problema del puerto MIdI de la M-Audio. En otro caso no lo puedo entender.
Subir
#3 por Dark-Mt el 05/06/2008
Ni idea, siento no poder ayudarte. Yo mi teclado midi EMU lo conecté por usb directamente al MacBook Pro y creo que instalé algo del CD que me venía, pero vamos, que funcionó al instante. Nunca lo he conectado por midi ni al mac ni a un pc.
Subir
#4 por txemicortxea el 06/06/2008
Podría ser el teclado? No creo que te sirva mi caso pero por si acaso te lo comento. Yo tengo una m-audio pre (tarjeta externa) con pc y me ocurre lo siguiente. Unicamente consigo hacer funcionar mi teclado (controlador midi) si lo conecto al ordenador via usb mientras aparece en la pantalla el logotipo windows, sino no funciona. No se porque pero pensé que el teclado no funcionaba.
Subir
#5 por ChoPraTs el 06/06/2008
Pues al final fueron los cables. Con otra tarjeta funcionan, y con esta no. Tuve que comprar otros 2 cables MIDI. Sí, ya sé... parece increíble. Los cables MIDI en teoría son todos estándar... Pero ya ves.

Ahora sin embargo tengo un problema más serio. Cada vez que configuro Kontakt o Kontakt Player para que use la M-Audio Fast Track Pro, cuando cierro la aplicación y la vuelvo a abrir me produce un Kernel Panic.
Subir
#6 por Dark-Mt el 06/06/2008
Que versión de SO tienes? Es totalmente compatible tu interfaz, y en ese caso has actualizado los drivers?
Subir
#7 por ChoPraTs el 06/06/2008
Dark-Mt escribió:
Que versión de SO tienes? Es totalmente compatible tu interfaz, y en ese caso has actualizado los drivers?


Tengo la 10.5.3. Los drivers que he instalado son los de la web de M-Audio, aunque especifican para el sistema 10.5.1 (con lo cual hasta que no saquen algo actualizado para la 10.5.3 no me quejaré mucho...)

Posiblemente sea eso. He probado con drivers anteriores que funcionan en Leopard, y pasa lo mismo.
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo