Error al iniciar QJackCTL

shirubio
#1 por shirubio el 03/07/2020
Hola, estoy usando Ubuntu-Studio lo instale hace unos dias en una notebook CX216, y me da el siguiente error al tratar de iniciar QjackCTL:
PD: anteriormente lo habia probado instalarlo en una netbook del "conectar igualdad" e iniciaba bien.

Error
D-BUS: El servidor Jack no puede iniciarse

No puede contectarse al servidor Jack como cliente.
-La operacion global fallo
-No puede conectarse el servidor.
Por favor revise la ventana de mensajes para mas informacion.


12:48:55.304 Reiniciar estadísticas.
12:48:55.337 Cambios en las conexiones ALSA.
12:48:55.366 D-BUS: Disponible (org.jackaudio.service aka jackdbus).
Cannot connect to server socket err = No existe el archivo o el directorio
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
12:48:55.670 Cambió el gráfico de conexiones ALSA.
12:48:59.306 D-BUS: El servidor JACK no puede iniciarse. Disculpa
Cannot connect to server socket err = No existe el archivo o el directorio
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Fri Jul 3 12:48:58 2020: Starting jack server...
Fri Jul 3 12:48:58 2020: JACK server starting in realtime mode with priority 10
Fri Jul 3 12:48:58 2020: self-connect-mode is "Don't restrict self connect requests"
Fri Jul 3 12:48:59 2020: Acquired audio card Audio0
Fri Jul 3 12:48:59 2020: creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
Fri Jul 3 12:48:59 2020: ERROR: ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
Fri Jul 3 12:48:59 2020: Released audio card Audio0
Fri Jul 3 12:48:59 2020: ERROR: Cannot initialize driver
Fri Jul 3 12:48:59 2020: ERROR: JackServer::Open failed with -1
Fri Jul 3 12:48:59 2020: ERROR: Failed to open server
Fri Jul 3 12:49:00 2020: Saving settings to "/home/shirubius/.config/jack/conf.xml" ...
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 883, resource id: 12667603, major code: 40 (TranslateCoords), minor code: 0
12:49:03.946 No puede conectarse al servidor JACK como cliente. - La operación global falló. - No puede conectarse al servidor. Por favor revise la ventana de mensajes para mas información.
Cannot connect to server socket err = No existe el archivo o el directorio
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1064, resource id: 12668286, major code: 40 (TranslateCoords), minor code: 0
Subir
vud1
#2 por vud1 el 06/07/2020
igual deberias meter este hilo en el foro de linux. Allá habrá más linuxeros que puedan ayudarte...

Sobre el error.. no da muchas pistas.. Por lo que parece no se puede lanzar el servidor jack y, por tanto, el qjackctl no se puede conectar a él...

la cosa es porque el server no se puede lanzar...

se me ocurren dos cosas:

a) o que el server jack no está instalado, pero si has instalado qjackctl desde apt, el servidor jack se instala como dependencia.. así que en principio esto no deberia pasar.

b) un error de conf en qjackctl que impide lanzar el jackd?

c) Más probable.. un tema de permisos? Tienes a tu usuario metido en el grupo audio?

Si nada de lo anterior te aclara, y por tener algo de luz.. prueba a cambiar el orden en el que ejecutas las cosas. Lanza primero el servidor jack y después lanza el qjackctl.. el qjackctl deberia conectarse al server jack según se lanza.

Para ello ejecuta "jack_control start" desde la consola. Y si no hay errores, lanza "qjackctl".
Subir
vagar
#3 por vagar el 06/07/2020
shirubio escribió:

Fri Jul 3 12:48:59 2020: ERROR: ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode


Posiblemente la interfaz esté usada por otro programa, quizá Pulseaudio. Es raro, porque Ubuntu Studio debería venir preparada para evitar ese tipo de conflictos, pero a saber si se ha instalado correctamente...
Subir
Hilos similares
Responder

Regístrate o para poder postear en este hilo