Instalacion de OS X en PC... en cristiano...

--6355--
#106 por --6355-- el 19/09/2005
GNU/Linux es el futuro.
Subir
--13211--
#107 por --13211-- el 19/09/2005
guitman escribió:
GNU/Linux es el futuro.


no... es el presente.... :)
Subir
Lamprolog
#108 por Lamprolog el 19/09/2005
sivsfa escribió:
guitman escribió:
GNU/Linux es el futuro.


no... es el presente.... :)


Para universitarios y gentes del mal_vivir :twisted:
Subir
--13211--
#109 por --13211-- el 19/09/2005
Lamprolog escribió:
sivsfa escribió:
guitman escribió:
GNU/Linux es el futuro.


no... es el presente.... :)


Para universitarios y gentes del mal_vivir :twisted:


:D :D


siempre tuve un mal vivir en el cuerpo.... :)
Subir
--6355--
#110 por --6355-- el 19/09/2005
sivsfa escribió:
guitman escribió:
GNU/Linux es el futuro.


no... es el presente.... :)


Es verdad,no sé por qué he dicho eso cuando para mí ES el presente,jeje.

Saludos.
Subir
solker
#111 por solker el 19/09/2005
autoy escribió:
Hola!

Toda una sorpresa que ver OSx86'ers por aquí ;) A ver si puedo resolver algunas dudas.
Tengo instalado el parche para ponerlo en castellano, pero está basado en el paquete multilenguaje de Tiger ppc y parece que las cosas están traducidas a medias (cosas como el menú apple o algunos items no lo están) aparte de provocar cuelgues en algunas aplicaciones (el activity monitor no va, la opción "run with rosseta" desaparece), de manera que no es para nada una solución óptima.
Parece que la reciente actualización del developer transition kit a 10.4.2 es ya totalmente multilenguaje y arregla muchos de los problemas que tenemos en esta 10.4.1 (se especula con el soporte de ciertas tarjetas gráficas bastante comunes)... habrá que esperar para salir de dudas...

En cuanto a la velocidad de Rosseta, pues probando Live, como comentaban mas arriba, fatal. Con Logic Express va francamente bien, bajas latencias (tengo core audio soportado :) y no demasiado consumo de CPU, aunque si mas del habitual. Con aplicaciones que no requieren excesiva potencia de proceso (Office, iwork, ilife...) las aplicaciones ppc se comportan en general muy bien para ser una emulación (no se si alguno aquí ha probado pearpc...) y se puede trabajar con ellas sin mayor problema, es asombroso lo bien que están integrados OSX y Rosseta.

En cuanto al arranque dual, pues he conseguido una instalación nativa junto a un XP preexistente sin cargarme la tabla de particiones. El proceso es bastante complejo e intervienen varias máquinas virtuales VMware, Linux y DD. Por lo tanto recomiendo instalar primero OSX y luego XP en el espacio de disco que hayais dejado libre, es el modo mas sencillo.

Si necesitais que explique algo en detalle sobre todo esto preguntad y respondo sin problemas. Que haya suerte a los que lo probéis!

saludos


Hombre!! un entendido en el tema, jeje ...

Abusando de tu hospitalidad :P ¿como puedo solucionar lo del "still waiting for root device"? he probado de todo, ahora mismo tengo instalado el xp, pero vacio, lo reinstale ayer, pq intente instalar el osx desde 0 con el sistema limpio y tampoco funciono, asi que si me lo tengo que cargar no importa mucho.

Para ponerte un poco en antecedentes, tenia xp, linux e intente instalar el osx, me salia el mensajito (el mensaje sale cuando arranco con -x -v, si dejo que salte la manzanita, me sale una señal de prohibido), quite el linux, y lo mismo, con el disco vacio, idem, y con otro hd el mismo resultado ¿alguna idea?

Un saludo.
Subir
autoy
#112 por autoy el 19/09/2005
Me das muy pocos datos, no se que estás usando... imagen Deadmoo de VMware? El DVD parcheado Release 1? Lo mas recomendable para una instalación limpia es usar este último y luego actualizar el kernel al maxxuss 0.5c que va genial.

Lo mas normal es que el error de root device lo de cuando tienes problemas con tu controladora IDE (estas usando disco SATA? Estas poniendo el disco en cable select en vez de master del primario?). Lo mas fácil para testear la compatibilidad es usar la imagen vmware de deadmoo y si todo va bien hacerte una instalación nativa con el dvd. También puedes echar un vistazo a la wiki de hardware compatible:

http://wiki.osx86project.org/wiki/index.php/HCLPart

e incompatible:

http://wiki.osx86project.org/wiki/index ... e_hardware

a ver si con esto vas tirando :)
Subir
solker
#113 por solker el 20/09/2005
Gracias por el interes autoy ...

La instalacion es la del dvd parcheados, con las indicacion de macuarium, el link del principio, no se que release sera, supongo que la 1.

Datos: veamos, la placa es supuestamente soportada (mejor dicho posiblemente soportada, ya que no esta dentro de las compatibles, aunque algunas de su familia si, o eso creo, y esta esta es las posibles) excepto la lan integrada y sonido ac'97, hasta aqui normal. Es una ASUS P4S800.

He probado 2 HD's. La historia: Probe de instalarla tal como tenia el ordena, 2 HD's en el canal primario, uno master y uno slave, y 2 Cdroms (lector dvd sony y grabadora dvd sony) en el canal secundario, el lector como esclavo y el grabador como master. No fue, asi que probe a quitar un HD, tampoco, deje solo Un HD y una unidad optica, el HD en el primario de master y los opticos, de las dos formas, tampoco. Y por ultimo, solo deje el canal primario con el HD de master y el dvd de esclavo. Con esta ultima copnfiguracion, probe con el win instalado, y el resto del disco libre para particionar con el OSX, tambien probe, a hacer una particion AF, probe particion darwin (todas ellas echas con una ubuntu live cd), todas con el mismo resultado. Despues lo intente sustituyendo el HD por el otro, configurado tambien como master: mismo resultado. Los 2 HD's son ATA 133.

Ya sospecho que hay algo que no deja instalar, puede ser el controlador IDE, o algo, pense primero que podria ser el HD, pero al probar con el otro, que son de distintas marcas (Maxtor y Seagate, mas estandard imposible) supuse que no seria de alli.

El caso es que la placa no es incompatible a priori, pero tampoco pone que sea compatible.

La tarjeta de video (una GeForce2 MX 400) no es compatible con acelerador, pero si en modo VESA 3.0.

Y estas son las indagaciones que he echo, yo supongo que el problema estara en la placa, el procesador tiene todas las extensiones, asi que no se. Las listas que pones ya las estuve mirando, y me lance porque a priori no hay nada del todo incompatible.
Subir
autoy
#114 por autoy el 20/09/2005
... sin embargo no me dices nada del chipset. Los Intel van bien pero el resto pueden dar problemas.

Si tu placa soporta SATA alguna gente ha resuelto este problema habilitando el soporte SATA en la BIOS, aunque luego vayas a instlalar OSX en un disco PATA.
Subir
haku
#115 por haku el 20/09/2005
autoy escribió:
Hola!
En cuanto al arranque dual, pues he conseguido una instalación nativa junto a un XP preexistente sin cargarme la tabla de particiones. El proceso es bastante complejo e intervienen varias máquinas virtuales VMware, Linux y DD. Por lo tanto recomiendo instalar primero OSX y luego XP en el espacio de disco que hayais dejado libre, es el modo mas sencillo.

Si necesitais que explique algo en detalle sobre todo esto preguntad y respondo sin problemas. Que haya suerte a los que lo probéis!

saludos


Hola wenas...

A ver si puedes explicar mas detalladamente como hacer lo de arranque dual, paso a paso, o si hay algun tutorial por ahi...

SAludos!
Subir
autoy
#116 por autoy el 20/09/2005
Intentaré resumir la instalación de la manera mas sencilla posible, aunque hay cantidad de tutoriales en la wiki de osx86 project y en los foros de 360hacker.

Lo mas sencillo es empezar con un disco vacío sin particionar. Arrancas la instalación y en la pantalla de bienvenida abres disk utility (no voy a pararme a explicar como funciona disk utility). Si ya tienes particionado el disco puedes borrar todas las particiones desde aquí. Creas 2 partciones, la primera como espacio vacío (sin particionar, para winXP) y en la segunda creas una partición HFS+ (journaled) donde va a ir OSX. Es importante que la partición de espacio vacío vaya antes de la HFS+, si no winXP no será capaz de ser instalado en C:\

Una vez particionado el disco cierras disk utility y prosigues la instalación. OSX detectará una partición HFS+ y te pregunta si quieres instalar ahi. Instala todo hasta el final, reinicia, crea tu cuenta etc. Cuando OSX este funcionando es momento de instalar XP.

Instala XP en el espacio vacío que has creado (puedes hacerlo con NTFS si quieres pero OSX no podrá escribir en ella, yo prefiero hacerla FAT32). Despues de crear la nueva partición verás que se llama E:\ así que hay que arreglarlo, de modo que abandona la instalación tras particionar y vuelve a a arancar la instalación del CD. Ahora verás que el volumen de destino es C:\

Sigue las instalación normal de XP asta el final hasta que lo tengas listo y funcionando. Ahora hay que hacer un arranque dual. Busca en el DVD de instalación de OSX el fichero de arranque llamado chain0 y cópialo a C:\
Modifica el archivo boot.ini (quitale el "solo lectura" y cuando acabes de editarlo vuélveselo a poner) añadiendo la siguiente línea al final:

C:\chain0="Mac OS X"

Puedes modificar también en el boot.ini el tiempo de espera del menú de selección.
Al reiniciar te aparecerán los dos sistemas para elegir. Si eliges OSX te entra en el boot de darwin (OSX) y eliges el disco en el que está instalado.

...y eso es todo :)
Subir
autoy
#117 por autoy el 20/09/2005
En cuanto al problema del root device, también he leído que puede ser un problema del ACPI, asi que prueba con las siguientes opciones de arranque en darwin:

platform=x86pc
platform=acpi:x86pc
platform=acpi|x86pc

si alguna de ellas te va bien siempre puedes editar el com.apple.Boot.plist y añadirla, igual que se puede hacer con el Graphics Mode etc.
Subir
haku
#118 por haku el 20/09/2005
autoy muchas gracias, funcionando a la perfeccion :)

SAludos!
Subir
solker
#119 por solker el 20/09/2005
autoy escribió:
... sin embargo no me dices nada del chipset. Los Intel van bien pero el resto pueden dar problemas.

Si tu placa soporta SATA alguna gente ha resuelto este problema habilitando el soporte SATA en la BIOS, aunque luego vayas a instlalar OSX en un disco PATA.


Ok, cierto ... se me fue de la olla ;) es un SiS 648FX. La placa no soporta SATA, asi que eso no sera. Probare lo del ACPI ahora mismo. Ya te cuento.

Un saludo
Subir
Midicenter
#120 por Midicenter el 20/09/2005
Buen dato, autoy :wink:
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo