Problemas con mi tarjeta de sonido.

EgArOtH-DrUms
#1 por EgArOtH-DrUms el 22/08/2008
Buenas gente, llevo un tiempo siguiendo el foro de hispasonic y en concreto el apartado de linux, yo en el pasado estuve bastante tiempo usando ubuntu y knoppix pero por temas laborales tuve que volver a xp, el caso es que hace relativamente poco tiempo estoy pensando en cambiarme a ubuntu, pues esta misma tarde he metido un live cd con ubuntu lts 8.04 y el caso es que tengo una tarjeta de sonido tascam us-122 y no me sale configurada ni nada por el estilo. Bien encontre este link con una posible solucion: https://help.ubuntu.com/community/TASCAM_US-122, el caso es que no se si por tratarse de un live cd o por que motivo no he podido configurar la tarjeta de sonido, queria preguntaros si alguien tiene funcionando esa tarjeta con ubuntu y si me funcionara con ubuntu studio o 64 studio. Pregunto esto porque si no me equivoco creo que ni ubuntu studio ni 64 studio tienen live cd y queria asegurarme antes de instalar. Por lo demas todo perfecto. Ya me comentais... Hay que ver como ha evolucionado el tema linux y hay que ver las distros mas guapas y atractivas que hay.

Bueno gracias de antemano por la info. Un saludo gente.
Agur!
Subir
javuchi
#2 por javuchi el 23/08/2008
El Live-CD es muy limitado a la hora de instalar y ejecutar nuevos drivers.
En mi opinión deberías lanzarte a la piscina e instalarlo, y darte tiempo hasta que te acostumbres a la forma en que trabaja Linux con el audio.

Ah, directamente instala ubuntu studio, ya viene con muchas cosas configuradas. Pasa de la versión standard.

Saludos.
Subir
EgArOtH-DrUms
#3 por EgArOtH-DrUms el 23/08/2008
Bueno ya me decidi e instale ubuntu studio, todo genial, muy bien instalado y todo super rapido, el tema lo tengo con la tarjeta tascam us-122 y los driver alsa, estoy intentando actualizar los driver...tengo los 1.0.16 o 15 en algunos casos y quiero instalar todos los drivers alsa 1.0.17 y no se bien como hacerlo, me he descargado los paquetes, descomprimo y cuando voy a hacer el ./configure me aperece el siguiente error
Alguien escribió:
root@EgArOtH:~/alsa-utils-1.0.17# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether NLS is requested... yes
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
y no se muy bien como solucionarlo. Aguien podria darme algun consejo tanto para instalar los drivers alsa como para hacer rular mi tarjeta de sonido en el S.O. Muchas gracias de antemano. Agur.
Subir
javuchi
#4 por javuchi el 24/08/2008
Una pregunta: ¿no te va con el ALSA que viene con el Ubuntu studio?

Prueba eso antes de nada.

Si sigue sin funcionar, tienes que instalar el module-assistant antes de compilar eso que quieres:

apt-get install module-assistant

Después ejecutarlo desde la consola (module-assistant), y en el menú, darle a UPDATE y a PREPARE. Ello te instala todo lo necesario para compilar nuevos módulos.
Subir
EgArOtH-DrUms
#5 por EgArOtH-DrUms el 24/08/2008
No con el alsa que venia en el ubuntu stdio no me iba y despues de googlear durante bastante horas descubri en un foro en ingles que en ubuntu studio mi tarjeta de sonido tiene un problema con los buses cuando hacia esta accion:
Alguien escribió:
sudo fxload -s /path/to/ld2-ezusb.hex -I /usr/share/alsa/firmware/usx2yloader/us122fw.ihx -D /proc/bus/usb/002/003
el device de mi tarjeta cambiaba y nunca podia hacer el usx2yloader... (los ultimos parametros son el bus y el device que ves cuando haces un lsusb) nose si tendra solucion o no pero al final me he instalado el 64studio y la verdad que lo he configurado en 10 minutos. Se me enchufo la lucecita de la tarjeta de sonido y puedo reproducior audio, no se si podre grabar o hacer uso del midi, ahora lo probare.

Aun asi tengo algo que no me cuadra demasiado, cuando hago un asoundconf list la tarjeta de audio no me aparece en la lista y cuando uso el control de volumen me dice algo sobre el gstream o que no hay un dispositivo de audio configurado. Alguien sabria que puede pasar??

Muchas gracias de antemano y gracias por la ayuda javuchi.

Saludos.
Subir
javuchi
#6 por javuchi el 25/08/2008
El gstreamer es el manejador de audio del Gnome. Si estás en gnome, vete al menú Sistema->Preferencias->Sonido, y ahí pon el interface de audio que te interesa.
A ver si así te va.

El gstreamer no lo necesitas para las aplicaciones jack, pero te será necesario para ejecutar videos y reproductores standard de gnome.
Subir
EgArOtH-DrUms
#7 por EgArOtH-DrUms el 25/08/2008
El problema realmente no se donde puede estar, abro un terminal y ejecuto el alsaconf y no me aparece la tarjeta de sonido tascam, y si uso el comando asoundconf list tampoco me aparece la tarjeta de sonido. Lo extraño que es que la tarjeta funciona, puedo reproducir audio... no se por donde pueden ir los tiros.

Saludos gente y muchas gracias de antemano. Gracias javuchi.
Subir
javuchi
#8 por javuchi el 25/08/2008
Quizá esté reconocida como OSS pero no como ALSA. Mira a ver que encuentras por ahí.

(OSS es el protocolo antiguo de Linux. Fue sustituido hace unos años por ALSA, pero todavía existen tarjetas con driver solo para OSS)
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo