Sin audio

#1 por uee el 12/05/2009
Buenas, tengo un problemilla, a ver si alguien me ayuda. Voy a intentar poner todos los detalles para hacerlo mas facil.

Tengo un Dell Inspiron 640m (portatil) con Windows XP Media Center SP2, con tarjeta de sonido integrada en la placa base que es de intel. Los datos del everest los pongo al final.

Me he quedado sin sonido en el ordenador, para que os hagais una idea, los controladores aparecen instalados y funcionando correctamente, no hay ningun tipo de fallo según Windows, ni triagulos ni exclamaciones en amarillo en el administrador de dispositivos en ninguna parte, todo esta habilitado y funciona correctamente. Sin embargo si voy a Panel de control- Dispositivos de audio, lo que me pone es que no hay ningún dispositivo de audio. Si por ejemplo intento reproducir algo con winamp me sale el mensaje: [Error Nullsoft DirectSound v 2.49] Controlador DirectSound incorrecto. Instale los controladores correctos o seleccione otro dispositivo en la configuración. Codigo de error: 88780078

He probado a descargar los drivers del chipset de la placa base (desde dell support, porque en intel no estoy seguro de que tengo que bajar:Chipsets - Chipset information and downloads ). Los he instalado, tambien he bajado desde dell support los drivers sigmatel originales que me venian con el ordenador (Sigmatel HD audio codec), he probado a actualizar este controlador desde las Propiedades de Dispositivos de audio, he bajado el Microsoft UAA HD bus driver for audio, he bajado la ultima version de Directx (9.0c). He ido a servicios y he comprobado que Windows Audio esta en automatico y funcionando. Tambien probe algo que lei, que consistia en ir a C:/Program files/Sigmatel/C-Major Audio/WDM y ejecutar el archivo suhlp.exe, tampoco se soluciono. He leido millones de temas en foros sobre esto sin encontrar ninguna solución.

El problema surgio cuando dehabilite en Dispositivos de audio- Hardware, el Microsoft WINMM WDM Audio Compatibility Driver, pensando que si no funcionaba como esperaba (estaba intentando configurar un tema del Sonar 8) podría habilitarlo de nuevo. Pero aquello desapareció y no lo volvi a ver. No he visto descargas de eso por separado, por eso baje el UAA y el Directx, y he instalado los drivers del chipset y los de sigmatel en todos los ordenes posibles, primero uno luego el otro, reiniciando etc... y nada.

A ver si alguien sabe como va esto, os agradezco la ayuda...

Aqui esta lo del Everest, supongo que sobra información:

--------[ Resumen ]-----------------------------------------------------------------------------------------------------

Ordenador:
Sistema operativo Microsoft Windows XP Media Center Edition
Service Pack del Sistema Operativo Service Pack 2
DirectX 4.09.00.0904 (DirectX 9.0c)

Placa base:
Tipo de procesador Mobile DualCore Intel Pentium M, 1833 MHz (11 x 167)
Nombre de la Placa Base Dell MXC061
Chipset de la Placa Base Intel Calistoga i945GM/PM
Memoria del Sistema 2038 MB (DDR2-533 DDR2 SDRAM)
Tipo de BIOS Phoenix (03/16/06)

Monitor:
Tarjeta gráfica Mobile Intel(R) 945GM Express Chipset Family (224 MB)
Tarjeta gráfica Mobile Intel(R) 945GM Express Chipset Family (224 MB)

Multimedia:
Tarjeta de sonido Intel 82801GBM ICH7-M - High Definition Audio Controller [A-1]




--------[ Placa base ]--------------------------------------------------------------------------------------------------

Propiedades de la Placa Base:
Identificación de la Placa Base
Nombre de la Placa Base Dell MXC061

Propiedades del chipset del Bus:
Tipo de Bus Intel Direct Media Interface

Fabricante de la Placa Base:
Nombre de la empresa Dell Computer Corporation
Información sobre el producto http://www.dell.com
Descarga de la BIOS http://support.dell.com


--------[ Chipset ]-----------------------------------------------------------------------------------------------------

[ Puente Norte: Intel Calistoga i945GM/PM ]

Propiedades del puente Norte:
Puente Norte Intel Calistoga i945GM/PM
Revisión 03
Forma del componente 1202 Pin FC-BGA
Tamaño del componente 3.4 cm x 3.4 cm
voltaje del núcleo 1.5 V
In-Order Queue Depth 12

Controlador de memoria:
Tipo Dual Channel (128 bits)
Modo Activo Dual Channel (128 bits)

Tiempos de Memoria:
CAS Latency (CL) 4T
RAS To CAS Delay (tRCD) 4T
RAS Precharge (tRP) 4T
RAS Active Time (tRAS) 11T

Corrección de errores:
ECC No soportado
ChipKill ECC No soportado
RAID No soportado
ECC Scrubbing No soportado

Slots de memoria:
Slot DRAM nº1 1024 MB (DDR2-533 DDR2 SDRAM)
Slot DRAM nº2 1024 MB (DDR2-533 DDR2 SDRAM)

Fabricante del chipset:
Nombre de la empresa Intel Corporation
Información sobre el producto http://www.intel.com/products/browse/chipsets.htm
Descargar el controlador http://support.intel.com/support/chipsets/index.htm

[ Puente Sur: Intel 82801GBM ICH7-M ]

Propiedades del puente Sur:
Puente Sur Intel 82801GBM ICH7-M
Revisión / Stepping E1 / A1
Forma del componente 652 Pin mBGA
Tamaño del componente 3.1 cm x 3.1 cm
voltaje del núcleo 1.5 V

High Definition Audio:
Tipo de controlador de audio Intel 82801GB(M) ICH7
Nombre del Codec SigmaTel STAC9200
Identificación del Codec 83847690h
Codec Revision 00102201h

Controlador PCI Express:
PCI-E x1 port #1 Vacío
PCI-E x1 port #2 En uso @ x1 (Intel(R) PRO/Wireless 3945ABG Network Connection [NoDB])
PCI-E x1 port #4 Vacío

Fabricante del chipset:
Nombre de la empresa Intel Corporation
Información sobre el producto http://www.intel.com/products/browse/chipsets.htm
Descargar el controlador http://support.intel.com/support/chipsets/index.htm


--------[ Audio de Windows ]--------------------------------------------------------------------------------------------

midi-in.0 0000 0000 In From MIDI Yoke: 1
midi-in.1 0000 0000 In From MIDI Yoke: 2
midi-in.2 0000 0000 In From MIDI Yoke: 3
midi-in.3 0000 0000 In From MIDI Yoke: 4
midi-in.4 0000 0000 In From MIDI Yoke: 5
midi-in.5 0000 0000 In From MIDI Yoke: 6
midi-in.6 0000 0000 In From MIDI Yoke: 7
midi-in.7 0000 0000 In From MIDI Yoke: 8
midi-out.0 0000 0000 Out To MIDI Yoke: 1
midi-out.1 0000 0000 Out To MIDI Yoke: 2
midi-out.2 0000 0000 Out To MIDI Yoke: 3
midi-out.3 0000 0000 Out To MIDI Yoke: 4
midi-out.4 0000 0000 Out To MIDI Yoke: 5
midi-out.5 0000 0000 Out To MIDI Yoke: 6
midi-out.6 0000 0000 Out To MIDI Yoke: 7
midi-out.7 0000 0000 Out To MIDI Yoke: 8


--------[ Audio PCI/PnP ]-----------------------------------------------------------------------------------------------

Intel 82801GBM ICH7-M - High Definition Audio Controller [A-1] PCI



--------[ Sonido DirectX ]----------------------------------------------------------------------------------------------

[ Controlador primario de sonido ]

Propiedades del dispositivo DirectSound:
Descripción del dispositivo Controlador primario de sonido
Módulo del controlador
Buffers principales 0
Tamaño de muestra min/máx de los buffers secundarios0 / 0 Hz
Formatos de sonido de los buffers principales Ninguno
Fomatos de sonido de los buffers secundarios Ninguno
Buffers de sonido (total/libres) 0 / 0
Buffers de sonido estáticos (total/libres) 0 / 0
Buffers de sonido fluidos (total/libres) 0 / 0
Buffers de sonido 3D (total/libres) 0 / 0
Bufers de sonido 3D estáticos (total/libres) 0 / 0
Buffers de sonido 3D fluidos (total/libres) 0 / 0

Funciones del dispositivo DirectSound:
Controlador certificado No
Dispositivo emulado No
Tamaño de muestra preciso No soportado
DirectSound3D No soportado
Creative EAX 1.0 No soportado
Creative EAX 2.0 No soportado
Creative EAX 3.0 No soportado


--------[ Música DirectX ]----------------------------------------------------------------------------------------------

[ Mapeador Microsoft MIDI [Emulado] ]

Propiedades del dispositivo DirectMusic:
Descripción del dispositivo Mapeador Microsoft MIDI [Emulado]
Tipo de sintetizador Hardware
Clase de dispositivo Puerta de salida
Tipo de dispositivo Windows Multimedia
Canales MIDI 16

Funciones del dispositivo DirectMusic:
Juego de instrumentos GP integrados No
Juego de sonidos Roland GS integrados No
DirectSound No soportado
Colección de ejemplos DLS L1 No soportado
Colección de ejemplos DLS L2 No soportado
Puerto externo MIDI No
Tamaño de la memoria DLS adosada No
Puerto compartido Soportado
Efecto Coro No soportado
Efecto Retraso No soportado
Efecto Reverberación No soportado

[ Out To MIDI Yoke: 1 [Emulado] ](Hay 7 más)

Propiedades del dispositivo DirectMusic:
Descripción del dispositivo Out To MIDI Yoke: 1 [Emulado]
Tipo de sintetizador Hardware
Clase de dispositivo Puerta de salida
Tipo de dispositivo Windows Multimedia
Canales MIDI 16

Funciones del dispositivo DirectMusic:
Juego de instrumentos GP integrados No
Juego de sonidos Roland GS integrados No
DirectSound No soportado
Colección de ejemplos DLS L1 No soportado
Colección de ejemplos DLS L2 No soportado
Puerto externo MIDI Sí
Tamaño de la memoria DLS adosada No
Puerto compartido Soportado
Efecto Coro No soportado
Efecto Retraso No soportado
Efecto Reverberación No soportado


[ In From MIDI Yoke: 1 [Emulado] ](Hay 7 más)

Propiedades del dispositivo DirectMusic:
Descripción del dispositivo In From MIDI Yoke: 1 [Emulado]
Tipo de sintetizador Hardware
Clase de dispositivo Puerta de entrada
Tipo de dispositivo Windows Multimedia
Canales MIDI 16

Funciones del dispositivo DirectMusic:
Juego de instrumentos GP integrados No
Juego de sonidos Roland GS integrados No
DirectSound No soportado
Colección de ejemplos DLS L1 No soportado
Colección de ejemplos DLS L2 No soportado
Puerto externo MIDI Sí
Tamaño de la memoria DLS adosada No
Puerto compartido No soportado
Efecto Coro No soportado
Efecto Retraso No soportado
Efecto Reverberación No soportado


[ Microsoft Synthesizer ]

Propiedades del dispositivo DirectMusic:
Descripción del dispositivo Microsoft Synthesizer
Tipo de sintetizador Programas
Clase de dispositivo Puerta de salida
Tipo de dispositivo User-Mode Synthesizer
Canales de audio 2
Canales MIDI 16000
Voces 1000
Memoria disponible Memoria del Sistema

Funciones del dispositivo DirectMusic:
Juego de instrumentos GP integrados No
Juego de sonidos Roland GS integrados No
DirectSound Soportado
Colección de ejemplos DLS L1 Soportado
Colección de ejemplos DLS L2 Soportado
Puerto externo MIDI No
Tamaño de la memoria DLS adosada No
Puerto compartido No soportado
Efecto Coro No soportado
Efecto Retraso No soportado
Efecto Reverberación Soportado
Subir
#2 por monarca el 12/05/2009
sintetico lo tuyo... :mrgreen: usando la opcion de detectar hardware del panel de control no lo encuentra?
Subir
#3 por El Matagatos el 12/05/2009
uee escribió:

El problema surgio cuando dehabilite en Dispositivos de audio- Hardware, el Microsoft WINMM WDM Audio Compatibility Driver, pensando que si no funcionaba como esperaba (estaba intentando configurar un tema del Sonar 8) podría habilitarlo de nuevo. Pero aquello desapareció y no lo volvi a ver. No he visto descargas de eso por separado, por eso baje el UAA y el Directx, y he instalado los drivers del chipset y los de sigmatel en todos los ordenes posibles, primero uno luego el otro, reiniciando etc... y nada.


Esa es la unica informacion que es util tener :mrgreen: , pero dime por dios muchacho, por que hiciste eso? quien te dijo que lo deshabilitaras? Bueno, ve al administrador de dispositivos y coloca el menu ver y seleccionas ver dispositivos ocultos, verifica si aparece ahora eso que eliminaste y luego desinstalas todos los componentes relacionados con esa tarjeta de sonido, luego reinicias y windows ya podrá reconocer el dispositivo y lo instalará nuevamente. Asi deberias dejar de tener problemas. Luego bajate los Asio4all, los instalas y ya no tendras problemas con Sonar.
Subir
#4 por El Matagatos el 12/05/2009
No comprobe el link, pero al parecer puedes descargar el driver desde aca.

http://www.versiontracker.com/dyn/moreinfo/win/65917

De todas formas se deberia instalar al instalar el chipset de intel.
Subir
#5 por uee el 12/05/2009
Gracias a todos por contestar, ya se que es una sobrada de informacion pero era para no andar luego dando vueltas sobre lo mismo.

monarca, lo de detectar hardware ya lo probe pero no es el problema, si la tarjeta la detecta, esta todo instalado y funciona, de hecho me he bajado el plugin de asio para winamp y reproduce musica perfectamente, y el sonar tambien funciona con el asio.

harpocrates666, ya he hecho tambien lo de dispositivos ocultos y no aparece eso, y la pagina que me has puesto, también la he mirado junto con otras y todas te remiten a windows update donde lo unico que puedes hacer es escanear tu pc para buscar actualizaciones a nivel general, pero esto en concreto no es ninguna actualizacion.

De todas formas tengo un lio importante, el chipset de intel esta dividido en 2 puentes, uno de ellos controla el sonido, y esta eso de Intel 82801GBM ICH7-M - High Definition Audio Controller [A-1] PCI, luego pone High Definition Audio:
Tipo de controlador de audio Intel 82801GB(M) ICH7
Nombre del Codec SigmaTel STAC9200

..y no se si el controlador es sigmatel o intel o que pasa, en dispositivos de audio habla de Sigmatel HD audio codec, ya no se ni que son codecs ni que controladores de que cosas..

Por lo menos tengo el winamp funcionando, gracias por responder y a ver si se os ocurre algo.
Subir
#6 por El Matagatos el 12/05/2009
uee escribió:
Gracias a todos por contestar, ya se que es una sobrada de informacion pero era para no andar luego dando vueltas sobre lo mismo.

monarca, lo de detectar hardware ya lo probe pero no es el problema, si la tarjeta la detecta, esta todo instalado y funciona, de hecho me he bajado el plugin de asio para winamp y reproduce musica perfectamente, y el sonar tambien funciona con el asio.



??? no entiendo, cual es tu problema en realidad? dices primero que no tienes audio, luego que si, dices que en el panel de control no hay ningun dispositivo con audio y luego dices que esta todo correctamente instalado y que sonar te funciona perfectamente y winamp tambien. Entonces que pasa? me has confundido.
Subir
#7 por uee el 12/05/2009
A ver, no tengo audio, he conseguido bajar un plugin para que winamp funcione con asio, y el sonar funciona tambien con asio, solo para ir tirando de momento, pero no funcionan los sonidos normales de windows ni los videos de youtube ni nada parecido. Todo lo que quede fuera de winamp y sonar no suena, de hecho suena el altavoz interno del portatil que hace un pitido con cada aviso de windows y es una putada.

La tarjeta aparece instalada correctamente, los drivers aparecen instalados correctamente, segun windows no hay nada mal instalado, pero si voy a Panel de Control - Dispositivos de sonido y audio, dice que no hay ningun dispositivo de audio. Si abro el mezclador no aparece tampoco nada porque no detecta ningun dispositivo de audio.

PERO, si en la misma ventana de Dispositivos de sonido y audio, voy a la pestaña Harware, aparecen: Sigmatel High Definition Audio CODEC, Audio Codecs, Legacy Audio Drivers, Media Control Devices, Legacy Video Capture Devices, y Video Codecs, y todos esos dispositivos estan habilitados y funcionan correctamente.

Gracias de nuevo, un saludo
Subir
#8 por El Matagatos el 12/05/2009
uee escribió:
A ver, no tengo audio, he conseguido bajar un plugin para que winamp funcione con asio, y el sonar funciona tambien con asio, solo para ir tirando de momento, pero no funcionan los sonidos normales de windows ni los videos de youtube ni nada parecido. Todo lo que quede fuera de winamp y sonar no suena, de hecho suena el altavoz interno del portatil que hace un pitido con cada aviso de windows y es una putada.

La tarjeta aparece instalada correctamente, los drivers aparecen instalados correctamente, segun windows no hay nada mal instalado, pero si voy a Panel de Control - Dispositivos de sonido y audio, dice que no hay ningun dispositivo de audio. Si abro el mezclador no aparece tampoco nada porque no detecta ningun dispositivo de audio.

PERO, si en la misma ventana de Dispositivos de sonido y audio, voy a la pestaña Harware, aparecen: Sigmatel High Definition Audio CODEC, Audio Codecs, Legacy Audio Drivers, Media Control Devices, Legacy Video Capture Devices, y Video Codecs, y todos esos dispositivos estan habilitados y funcionan correctamente.

Gracias de nuevo, un saludo


:shock: el misterio del audio desaparecido.

Bueno esta claro que el problema es con el driver WDM, pero es que de verdad no se que has hecho con el, ves, por andar metiendo mano donde no corresponde, y probaste instalando Asio4all? bueno lo que haria yo es desinstalar el dispositivo de audio, lo hiciste eso? y windows ya deberia tener los driver correctos, te los volvera a instalar automaticamente, luego instala asio4all y te olvidas de hacer apaños raros para lograr que sonar funcione.
Subir
#9 por uee el 12/05/2009
Vale tio, perdona por tocar donde no debia, pero nadie me daba una solucion aqui https://www.hispasonic.com/foros/conflicto-asio4all-sigmatel/261584, ademas, que yo (quiza desde mi ignorancia) deshabilite aquello porque no me imagine que fuera a desaparecer de alli, normalmente deberia haber podido habilitarlo de nuevo sin mas.

Y lo del asio, me refiero a asio4all siempre, ya lo tengo instalado, todo eso esta detallado en el enlace que te he puesto arriba.

Gracias por seguir contestando
Subir
#10 por El Matagatos el 12/05/2009
uee escribió:
Vale tio, perdona por tocar donde no debia, pero nadie me daba una solucion aqui https://www.hispasonic.com/foros/conflicto-asio4all-sigmatel/261584, ademas, que yo (quiza desde mi ignorancia) deshabilite aquello porque no me imagine que fuera a desaparecer de alli, normalmente deberia haber podido habilitarlo de nuevo sin mas.

Y lo del asio, me refiero a asio4all siempre, ya lo tengo instalado, todo eso esta detallado en el enlace que te he puesto arriba.

Gracias por seguir contestando


Ya veo, bueno lo siento, te has topado con problema demasiado particular, es raro tener este tipo de problemas y ya se escapa a lo que el comun de la gente puede manejar, espero lo soluciones (por que a mi no se me ocurre como :mrgreen: ) y mejor seria juntar algo de pasta y comprarte alguna interfaz externa, ya sea la mas baratilla te dara menos problemas que los que estas teniendo ahora. Que siempre trabajar con la integrada es el primer paso que hay que superar (no tendras bajas latencias con la integrada, asi que lo mejor es disponer de algo especifico para audio y no para multimedia como lo es una tarjeta integrada)
Subir
#11 por uee el 12/05/2009
Lo se, algun dia me comprare una hercules rmx que viene con tarjeta, pero de momento no tengo un duro para eso. Gracias por preocuparte de todas formas, seguire investigando porque estos pitidos no se pueden quedar asi. Por cierto, si sabeis como desactivar el altavoz que viene integrado en el ordena os agradeceria que me lo explicaseis porque no aguanto muchos mas pitidos.

Un saludo
Subir
Respuesta rápida

Regístrate o para poder postear en este hilo