Sin sonido teclado midi-usb en Ardour

  • 1
A350
#1 por A350 el 21/07/2017
Buenas gente...


A ver si alguien puede ayudarme. Ando con debian y he conectado un teclado midi via usb , los drivers de sonido son alsa y he probado ardour pero sin resultado de hacer sonar el teclado midi.

Las conexiones jack están bien o eso creo.


Gracias de antemano .
Subir
vagar
#2 por vagar el 21/07/2017
Aquí se describe el proceso paso a paso, está en inglés. Aunque no se entienda el idioma se puede seguir el proceso en la pantalla:

Subir
A350
#3 por A350 el 21/07/2017
Gracias, el tema es que estoy con ardour2 y debería funcionar tambien, pero... nada, aun sigo en silencio :(
Subir
vagar
#4 por vagar el 21/07/2017
La primera versión de Ardour que soporta MIDI es la 3.0, de marzo de 2013:

https://community.ardour.org/node/6908
Subir
1
A350
#5 por A350 el 21/07/2017
OK, si.. en eso estaba.. pero a ver si consigo abrirlo pq no medeja crear sesion.

Me sale este error


http://i.imgur.com/NlFjNwO.png
Subir
vagar
#6 por vagar el 21/07/2017
No tienes bien configurado el kernel o los permisos. Es un poco lío.

Para empezar con el mundo del audio en Linux lo más recomendable es usar una distribución orientada al audio, como AVLinux, te toparás con muchos menos problemas:

http://www.bandshed.net/avlinux/
Subir
1
A350
#7 por A350 el 21/07/2017
si claro, las conocía.. pero supongo que alguna solución deber a ver.. Muchas gracias por tu tiempo @vagar Se agradece ;)


Si consigo arrancar esto, pasaré por aqui.
Subir
vagar
#8 por vagar el 21/07/2017
La solución es documentarte sobre lo que es un kernel de baja latencia y cómo se instala y configura en la distribución que estés usando, pero no es algo trivial. Se tarda menos en instalar una distribución ya preparada, que además tendrá preinstalado y preconfigurado mucho software que te va a facilitar las cosas. Depende de en qué quieras invertir el tiempo.

Aquí tienes documentación actual por si quieres pegarte con ello:

http://libremusicproduction.com/
Subir
A350
#9 por A350 el 21/07/2017
Gracias por el link!!

Perdona la pregunta pero. M

Seguro que el error es kernel de baja latencia?
Subir
vagar
#10 por vagar el 21/07/2017
El error es que jack no puede adquirir privilegios de trabajo en tiempo real. Para eso hace falta un kernel que lo permita y una serie de cambios en la configuración del sistema. Está documentado en varios sitios.
Subir
A350
#11 por A350 el 21/07/2017
OK.. gracias de nuevo, investigaré por si damos con la solución, gracias !!
Subir
A350
#12 por A350 el 21/07/2017
Subir
A350
#13 por A350 el 25/07/2017
Pues , retomo el tema por si alguien me ayuda. He probado AVLinux como me recomendaron y tampoco consigo hacer sonar el teclado midi que concetramente es este TRG-MK149

He probado Ardou3 en debian 8 y Ardour5 en AVLinux y no hay manera. He abierto el teclado por si tenía algún cable suelto ya a la desesperada y está todo correcto.

he mirado muchos tutos por youtube, pero no consigo hacerlo sonar.

En Ardour no es necesario Jack , ya que por lo que veo lo incorpora el programa en si. Lo que si hay que activar en terminal es a2jmidid -e y me activa el teclado usb, pero nada mas.

Alguna nueva recomendación gente?? o lo tiro por la ventana xD

Gracias de nuevo
Subir
vagar
#14 por vagar el 25/07/2017
#13

Con tan poca información es difícil ayudarte. Describe paso a paso lo que estás haciendo, a ver dónde está el problema. Ya sabes que tiene que haber conexiones físicas y conexiones en el software, y que para que haya sonido tiene que haber un software de síntesis de por medio capaz de recibir datos MIDI y generar una señal de audio como respuesta.
Subir
A350
#15 por A350 el 25/07/2017
Pues a ver amigo. Lo primero es la conexión y tengo en el teclado salida midi-out conectada al midi-in y de ahi al usb frontal de la torre del pc


El teclado enciende bien sin problemas conectado a la corriente con su tranformador oficial :p

Luego abro Ardour y añado una pista midi, previamente activo en terminal el a2jmidid -e que según lei en los foros de Ardour en Linux hay que hacerlo. Una captura http://i.imgur.com/qTpWmAb.png

las conexiones en Ardour cambio la ultima MIDI System por ALSA sequencer por aqui una captura http://i.imgur.com/hhyVODw.png

Y en preferencias de Ardour activo General MIDI http://i.imgur.com/h0CxV5B.png


No se si se me escapa algo .. Gracias @vagar !


EDITO: En conexiones de Ardour activo usb/midi como ves en la captura

http://i.imgur.com/LtHLM6m.png
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo