Ayuda comunicación midi entre dos teclados!

  • 1
David
#1 por David el 31/05/2017
Hola voy a salir de gira y me he encontrado el siguiente problema: Mis cambios de programa desde el maestro (nord stage 2) al esclavo (roland fa06) no funcionan .Llevo automatizados los program Change girando el dial de Nord y cambiando en el roland.
Los teclados funcionan perfectamente y por eso me extraña que no haya comunicacion midi entre ellos.
La última vez que funcionó había quitado el cable midi al in del roland y trabajé así un rato para después apagar.
Dos dias después encendí y puse el cable al midi in; empecé a cambiar presets desde el Nord y no funcionaban....(La comunicacion midi).
Puedo tocar canbiando manualmente uno y otro, para cada cancion pero no me parece profesional;además como decía: funciona todo perfectamente menos la sincronizacion midi.
Es como surrealista...
He llamado a Ate music y me han dicho que haga un backup de todo y que haga reset de fábrica para luego cargar los archivos pero al tener cerca compromisos musicales no quiero jugarmela, y a lo mejor hacerlo manual y adaptando cosas también.
Necesito ayuda!!!
Subir
Soundprogramer mod
#2 por Soundprogramer el 01/06/2017
#1 ¿Has revisado la configuración de recepcion de datos Midi del teclado esclavo?
Si el esclavo es el Roland FA deberías revisar si tiene habilitada la opción "Midi program Change" a enable.
Revisa el cable Midi o cámbialo por otro por si acaso. El conexionado no tiene misterios de ningún tipo,
asi que cable Midi Out del Nord al Midi In del Roland.
También deberías revisar en la página de configuración Midi del Nord las opciones de transmisión Midi del
Nord. Revisa y ajusta el mismo canal Midi, tanto en el Nord como en el Fantom.

Lo que me sorprende es que en Ate music te propongan un reset de fábrica para una simple configuración Midi. :desdentado:
Aunque he visto cosas peores.
Si acaso describe en detalle como tienes los ajustes Midi en cada Instrumento, asi te podremos ayudar mejor
¡Saludos!
Subir
alberto
#3 por alberto el 01/06/2017
Mira el ID del FA. Me dio más de un dolor de cabeza con el Integra.
Puede parecer para tontos, pero llevo una planilla escrita a cada bolo con toda la programación, datos, etc. Me ha salvado de más de un susto ;-)
Sigo el hilo.
Saludos!
Subir
David
#4 por David el 01/06/2017
Gracias por las respuestas, pero lo surrealista es que he probado con otro cable, tengo habilitadas todas las funciones de emisión y recepción e incluso el id tb que era por defecto el 17..
Ya digo: no toqué ningun ajuste global.Al día siguiente dejó de funcionar.
Noté ultimamente que en el roland movía unos knobs y al dejar de hacerlo se quedaban parpadeando los valores; como si estuviese moviendo los knobs, ha pasado alguna vez, pero ya no...
Estaba programado todo....
Tb el último día quité el cable del midi in en Roland porque quería mover el dial del Nord para trabajar en él, y al día siguiente (como muchas otras veces) lo conecté y nada...Estoy super rallado.
Subir
David
#5 por David el 01/06/2017
Estoy rezando hasta a mi abuelo para que funcione.
Los sonidos están y se puede cambiar un teclado y otro manualmente, pero también tendría que adaptar cosas porque tb hay pedales cc que envían senal al roland a través del Nord y no quiero hacer chapucillas; sino trabajar profesionalmente.Como estaba todo...
Subir
alberto
#6 por alberto el 01/06/2017
A ver otra tontuna...
¿No habrás cambiado el modo usb en el FA?
¿El modo Sync?
El nord tuyo no sé qué parámetros tiene... :triston:
Subir
David
#7 por David el 01/06/2017
Creo que no he probado con todos los id del fa pero siempre ha sido el 17.Puede cambiar?
No creo que sea eso pero mañana probaré...
He traído tb un kurzweil pc3x y no había comunicación entre ninguno de los tres.
Se me han podido desconfigurar el roland y el nord? O es el nord que no emite o el roland que no recibe?
Menuda locura...
Subir
alberto
#8 por alberto el 01/06/2017
Prueba con midiox. Es una herramienta genial y te detecta lo que envías desde el Nord. Si crees que manda bien ya sabes dónde tienes el tema.
El Integra tiene por defecto el ID 16. No sé en el FA.
Revisa el canal por el que recepciona cambios de studio sets.
Como te dijo antes Sergio, explica bien paso por paso para poder ayudarte.
Subir
David
#9 por David el 01/06/2017
#8 He probado con todos los ids y tampoco funciona.....
El midi 15 por cable convencional es el que utilizo para comunicar los dos teclados.El nord tiene en extern 15 y roland el 15 tb para controlar los Studio Sets.
Está como siempre ha funcionado.
Subir
Soundprogramer mod
#10 por Soundprogramer el 01/06/2017
David escribió:
Se me han podido desconfigurar el roland y el nord? O es el nord que no emite o el roland que no recibe?
Menuda locura...


Lo primero que debes hacer es comprobar el teclado fuente que causa el problema. Los dos a la vez supongo que
es muy poco probable que se desconfiguren simultáneamente, asi que paso a paso..

Empieza por lo básico:
Ajusta el mismo canal de recepción y transmision en ambos instrumentos, prueba a tocar algo en el teclado maestro y
revisa que el instrumento esté recibiendo datos de notas, on/off.
Prueba también con el Joystick, para ver si recibe cambios de modulación, pitchbend, etc.

Si lo conectas a un ordenador con interfaz Midi es mas sencillo empezar a diagnosticar los fallos de Midi
que se puedan dar. El programa que te recomienda alberto es muy válido para esa función, pues tiene
un modo de test para casos como este.

Y te repito, lo mejor es que indiques los ajustes que tienes en ambos instrumentos en sus correspondientes
páginas de edición, sino vamos a estar aquí dando palos de ciego porque iguál es una tontería. Es muy
raro que el Midi deje de funcionar por las buenas, asi que aquí algo se ha desconfigurado seguro.
Subir
pablofcid
#11 por pablofcid el 01/06/2017
Hola David.

No te agobies, que nunca ayuda, e intenta ser sistemático. En vez de probar los dos unidos (que ya sabes que genera un problema), deberías comprobar por partes, tal como te están sugiriendo. Ya luego llegará el momento de unir de nuevo.

¿El Roland sí te recibe las notas del Nord o ni eso?

Lo primero es confirmar que el teclado Nord está enviando lo que debe. Usa una aplicación de tipo 'MIDI monitor' y comprueba. Mira si salen los mensajes de nota, cambio de programa, CCs, y todo lo otro que necesites hacia el Roland. Fíjate que esté saliendo por las canales MIDI que necesitas, etc.
No te líes con lo del ID. Ese número sólo interviene a la hora de los mensajes SysEx, no tiene papel en el resto de los mensajes convencionales como los que tú dices que usas (progr. change, notas, CCs, etc.).

Si el Nord funciona, toca probar si el Roland está recibiendo.
Podrías hacerlo desde el Nord, pero como sabes que eso no te funciona, sería bueno que probaras a controlar el Roland desde otro equipo diferente. Podría ser mediante mensajes que metas en tu DAW / secuenciador preferido. Al fin y al cabo se trata de probar solamente si recibe y reacciona a los mensajes.
Mira si le llega OK en caso de conectarlo vía USB y recibir los mensajes del ordenador pero no si lo unes vía MIDI DIN 5 puntas, porque eso apuntaría a que tienes elegido un modo 'sólo USB' para MIDI que podrías tener que cambiar.

Procura ser exhaustivo al contarnos resultados para que podamos ayudarte más.

Por ejemplo, si el fallo es sólo con los progr. change, cuenta qué es lo que pasa. ¿Los ignora totalmente? ¿cambia a un sonido que no debe? ¿cambia siempre a un mismo sonido?... Por que esas respuestas conducen a posibles causas diferentes.

Incluso podría ser que el sinte hubiera recibido unos CCs de bank select que hayan hecho que apunte a un banco vacío y por tanto 'desoiga' los progr change que lleguen.

Pero es ridículo intentar plantearte soluciones sin que nos ilustre más sobre el problema que observas y esas pruebas 'separadas': ¿Envía el Nor (y qué envía)? ¿Recibe el Roland cuando no es desde el Nord? etc.
Subir
David
#12 por David el 01/06/2017
Gracias por las respuestas....Cuando llegue a casa más bien tarde os especifico las respuestas e incluso adjunto fotos.
Ya he traido un kurzweil pc3x y no recibía ni enviaba nada del roland....Lo tengo 3n modo midi de din no por usb y conectado el cable correspondiente...
Por eso digo que es surrealista porque esos ajustes globales no los toco apenas nunca....Es levantarse teniendo todo bien configurado y dejar de fumcionar.
No hay ningún tipo de comunicacion: ni de nota, velocidad, pitch, pedales cc.
Los cambios de studio set en el roland si responden con un switch asignado.Eso tb es un mensaje y el sustain.
Es la comunicación entre los dos....
Subir
pablofcid
#13 por pablofcid el 01/06/2017
¿Te has asegurado de probar a enviar por cada uno de los 16 canales, por si acaso?

Con lo que describes (no recibe nada vía MIDI DIN) te sugiero: prueba también por vía USB (unido a un ordenador, p.ej.). Con un poco de suerte es sólo cosa de lo que te han comentado, que esté configurado para usar sólo USB y que no tengas activada la parte MIDI, o que tengas activada la parte MIDI DIN no para que controle al propio sinte sino para que actúe como un interfaz vía USB para poder conectar equipos externos...
Aunque no suelas tocar esa parte de la configuración puede que lo hayas (o hayan) hecho sin que te des cuenta (por ejemplo tus hijos o sobrinos, o algún cotilla de las teclas que anduviera por ahí...).

Lo que dices del studio set y del sustain ¿puedes comentar un poco más? No termino de entender si lo que dices es que el mensaje de sustain sí que le llega ¿? O quiza ¿te refieres a que con un par de pedales unidos al Roland esas acciones sí las atiende? Que funcionen los pedales en el propio teclado no tiene nada que ver con la parte MIDI. Y me cuesta mucho imaginar que esos mensajes sí sean atendidos y todo el resto no.
Subir
alberto
#14 por alberto el 03/06/2017
¿Qué sabemos del tema?
Subir
David
#15 por David el 16/06/2017
Hola, disculpad la tardanza en responder, pero he estado de bolos.
He probado todo lo que me habéis dicho más restaurar a fábrica el nord (maestro); después he probado a ver si funciona el midi y nada.
También al revés y he puesto de master el roland y nada...ni envía ni recibe datos el Nord.
Ahora tendría que probar el Nord con otro sinte como el pc3x para ver si va bien y el problema es del Roland...
Ya probé a comunicar el kurzweil antes de formatear y no obtuve éxito...Aunque tengo que volverlo hacer.
Es la primera vez en mi vida me pasa esto y es una pesadilla surrealista.
Los teclados funcionan bien.Es el midi que no comunica..
He probado otros canales, el id del roland etc...Todo.
Solo me queda rezar para no tener que llevarlos a algún sítio.
Habría alguien de Madrid que pudiese venir a mi casa y acordamos un precio por la ayuda?
Heellpp compañeros!
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo