Logic pro "system overload" Solucionado!!

#1 por mike303 el 21/01/2008
Hola a todos, hace tiempo probe el logic y realmente estaba muy contento con el soft, pero como ya habia comentado entre otras personas el soft tenia un pifie que hacia q sin importar la potencia de la maquina q tengamos acusara un "system overload", y cortaba el audio por falta de potencia de proceso.

buscando por varios foros me entere que era un problema que sufria todo el mundo sin importar q maquina tengas, (macs pro, con 8 cores y varios gigas sufrian lo mismo con 3 tracks de audio corriendo).

el otro dia encontre un Script q soluciona el problema y paso a compartirlo con uds.

hay que buscar el scrip editor en: /Applications/AppleScript/

abrirlo y pegra este texto:

tell application "Logic Pro"
run
end tell
set the_lines to paragraphs of (do shell script "ps -U $USER")
set the_app to "Logic Pro"
set the_line to ""
repeat with this_line in the_lines
if this_line contains the_app then
set the_line to this_line
end if
end repeat
if the_line is "" then return
set the_pid to word 1 of the_line
do shell script "renice -20 " & the_pid password "TUPASSWORD" with administrator privileges

en TUPASSWORD hay que escribir el password del administrador de la compu.

lo que hace este script es q la maquina le de mas prioridad de procesos, al logi, por lo que hace que no se "atore".

despues de pegar eso hay que salvarlo como aplicacion y usarlo SIMPRE para ejecutar el logic. (ideal ponerlo en el desk y usarlo como shortcut).

si alguno sabe de programacion, (yo solo toco de oido) se dara cuenta q el comando "renice -20 " es el que esta dandole la "cantidad" de prioridad al proceso, por lo q lei podemos cambiar el valor del renice de -20 a 0, teniendo en cuenat que si nos acercamos a 0 podemos llegar a dejar sin % de procesador al OSX, y estarioamso en problemas nuevamente.

la data la saque de aca

http://www.logicprohelp.com/viewtopic.php?t=16909

espero q les sirva, y manden sus experiencias.

saludos

miguel.

macbook pro 2.16 /// 2g ram ///sata 100g 5400rpm.
Subir
#2 por kampasonic el 21/01/2008
hola estoy tratando de ponerlo pero no logro entender bien como se hace.... saludos
Subir
#3 por mike303 el 21/01/2008
en mi caso.. reduje en un 90% los cuelgues por picos de proceso... y no tuve tiempo de ver si con otro numero, podria dejarlo ams optimizado.

si alguno prueba con otros numeros, agardeceria q pase la data y con que maquina lo corre.

en mi caso es una macbook 2.16 con 2gigas de ram y rigido de 100g 5400, y como placa de audio una focusrite saffire.

saludos

miguel
Subir
#4 por powerstudios el 22/01/2008
Hey mike...fantastico....he echo una prueba y mi sistema.....100x100 nada de fallos,ultimamente tenia este mensaje de error un 90x al arrancar.Solo una duda me queda ya que algo mal puesto puede afectar, aunque ami ahora me va de marravilla,tu dices que donde pone tupasword pongo mi contrase₦a de administrador.
Bien....yo he deducido que borro lo de tupasword y justo ahi pongo mi contrase₦a......es asi ho no borro
nada.lo probe asi y por primera EN MUCHO TIEMPO nada de overloads.llevo dos horas con logic y nada de nada.perfecto..
hace tiempo lo esperaba esto.supongo que es un remedio asta que saquen la version 8.2.0 y ahi todo solucionado y optimizado mejor.....supongo.tambien me he dado cuenta que abriendo solo el logic desde que hice esto..el rendimiento es superior sin overloads tambien.pero lo are como dices tu...ejecuto el apple escript
y ya esta....lo unico que queda avierta en la pantalla dicha aplicacion...pero supongo es cuestion ya de poco tiempo....algo temporal......dime algo y gracias millllllll.....

MI MAQUINA. MACKBOOK PRO INTEL CORE 2 DUO- 2,40CPU,4GB RAM,HDD 160 7200RP.SOUNCARD-APOGEE ENSEMPLE.
Subir
#5 por monipeniminiwini el 22/01/2008
en logic 7 pro tb funciona?? tengo un powerbook g4,1,5 de procesador y 1 giga de ram logic 7.1
Subir
#6 por mike303 el 22/01/2008
hola, power..
powerstudios escribió:
Hey mike...fantastico....he echo una prueba y mi sistema.....100x100 nada de fallos,ultimamente tenia este mensaje de error un 90x al arrancar.Solo una duda me queda ya que algo mal puesto puede afectar, aunque ami ahora me va de marravilla,tu dices que donde pone tupasword pongo mi contrase₦a de administrador.
Bien....yo he deducido que borro lo de tupasword y justo ahi pongo mi contrase₦a......es asi ho no borro
nada.lo probe asi y por primera EN MUCHO TIEMPO nada de overloads.llevo dos horas con logic y nada de nada.perfecto..
quote]

si si, es asi como lo hiciste...remplazamdo esa palabra pro tu password....

este script te deja un pocode aire pero como cmente si afinas el numero -20... a valores mas bajos... le das todavia mas prioridad al logic.. pero obviamente no pdoes abrir otra aplicacion...

por otro lado, respondiendole a shaker...

shaker08 escribió:
en logic 7 pro tb funciona?? tengo un powerbook g4,1,5 de procesador y 1 giga de ram logic 7.1


si si funciona de hehco el scrip original es de un parche armado para FINALCUT, que un programador lo tiro en el forod e help del logic... lo testie tambien con protools y funciona.. es solo pareche para q el OSX le de mas prioridad a la aplicacion q queramos...

saludos...

miguel
Subir
#7 por powerstudios el 22/01/2008
OK MIKE...gracias...importante tambien para todos mike...saber si esto en osx lehopard funciona.yo no puedo
saberlo ya que por ahora me quedo con el tiger 10.4.10 asta que se solucione todo.supongo que sera lo mismo
claro.Y tambien decir que tu dices que puedo bajar ese valor,probare a bajarlo a la mitad.total cuando trabajo con logic no abro nada mas.y los 4 gb de ram que tengo aran para el uso de plugins de terceros.ya te digo que tal.....saludos att powerstudios....pero ya les vale ha los de apple tambien....esto lleva mucho tiempo mal.
como asta ahora no an dicho nada?venga ya esa actualizacion 8.0.2......pero yaaaaaaaaaaaaaaaaaa
Subir
#8 por electrosativa el 22/01/2008
Fantástico mike303,probado y como la seda.
Subir
#9 por neph el 23/01/2008
una prueba mas de que logic no solo en pc producia fallos :wink:
Subir
#10 por mike303 el 23/01/2008
ami me encnata el logic, pero meparece que pide demasaiada maquina, tanto el protools como el cubase en la misma maquina me piden menos procesador...

para mi tiene errores de programacion... porq es imposible q consuma tanto procesador con poco instrumentos virtuales corriendo.

saludos

miguel
Subir
#11 por powerstudios el 23/01/2008
Hey mike, que tal hombre?la verdad es que si pide demasiada maquina.pero que tal tu con el parche?
yo noto una mejora espectacular.y piensa que cuando apple lo solucione....pues ellos son programadores,
y creadores de dicho programa.....ira como la seda.creo que logic tendria que hacer ahora como hizo
steinberg con cubase 4,no sacar nada mas....y optimizar el consumo y rendimiento del programa.cruzemos los dedos sea pronto...pero tendran k hacerlo ya k son miles de personas las que se han y se estan quejando,ey mike...que version de cubase tienes?tira bien en tu macbook pro?saludos y aver que pasa...te agrege como amigo en hispasonic......ya iremos hablando.
Subir
#12 por ismy el 23/01/2008
Pues que queréis que os diga, pero con este script yo no he notado diferencia. Compilado y exportado como .app para cargar Logic y no se, he notado que igual iba mejor, pero lo mismo de siempre. Es mi impresión bajo un Macbook 2Gb RAM a 2Ghz.

Un saludo.
Subir
mod
#13 por faelitox el 23/01/2008
podrias subir por aqui un lso con el error que os salta?


a mi no me pasa eso, tengo el logic studio 8.0 en el macbook pro (core 2duo, 2,2GHz, 2gb ram, osx 10.4.10, tarjeta interna con buffer a 512), y va muy bien, de momento no lo uso para producir, pero las pruebas de rendimiento q he hecho aguanta como un campeon, yo diria q incluso aguanta mas que mi p4 HT 3400 con logic 5.5.


saludos!
Subir
#14 por Trotamundo el 23/01/2008
Lo he probado y la verdad es que va mejor, aunque salta el mensaje de system overload y el error sigue siendo (-10011), cierro el mensaje y sigo.
Pero es cierto que esto es algo que Apple va a tener que dar una solucion YA a este error. Si me sale otra vez, le mando un mensajito con la ventana del error.
Subir
#15 por animana el 23/01/2008
Hey alguien sabe que debiera poner si no tengo password en el ordenador?
Cuando dejo las comillas asi "" me las ensenha abajo en la ventana resultado

Gracias.
Subir

Hilos similares

Respuesta rápida
El topic está cerrado y no se admiten respuestas