Necesito un experto en MIDI

cronico
#16 por cronico el 01/06/2005
Joe pero ahora que pienso,.. cuando hago el 3er montaje, o sea:

RM1x------cablemidi------KEYSTATION(interfaz activado)----usb-------PC

Asi funciona bien el jodio cable,..., lo que no funciona bien es directo,..arf no se, voy a pillar un cable bueno, por probar, pero si funciona acabara con la poca logica que me queda ya para entender estas cosas xDD
Subir
llamaza
#17 por llamaza el 01/06/2005
Los cables midi llevan 5 contactos, pero que yo sepa ningun equipo los utiliza. Solo usan tres, los tres centrales. Puede ser que la Yamaha necesite todo el conjunto. De todas las maneras yo no descartaria los problemas de alimentacion. Intenta a ponerle pilas al teclado.
Vete a un dia y compra las mas baratas que tengas, yo hice la prueba y fue la que me soluciono el papelon hasta que compre una placa nueva.
Subir
cronico
#18 por cronico el 01/06/2005
Nada chico, yo no lo entiendo, me he comprado el mejor cable que tenian en la tienda, un Proel de 3 metros, 7,5€ y sigue comportandose igual en todos los casos, tengo el cerebro seco ya :(
llamaza, desgraciadamente mi teclado no puede ir a pilas :(
Subir
cronico
#19 por cronico el 01/06/2005
Sigo probando cosas, he cambiado el adaptador de corriente por otro q tengo y nada, sigue en las mismas, esto empieza a parece un expediente X :(
Incluso he sacado todo el equipo de donde lo tenia y lo he puesto en una habitacion mas grande con todos los cables bien extendidos y tal, a ver, pero nada,...
Subir
cronico
#20 por cronico el 01/06/2005
Y sigo con pruebas, es que lo monte como lo monte, siempre que la señal pasa por el pc y luego va a la RM1x todo va bien, pero como lo mande directo nada,..., he probado con varios cables tanto para usb como para midi y eso,..., os da alguna idea? jeje
Subir
cronico
#21 por cronico el 01/06/2005
Alguno como louvega o texvo que me parece que tb tiene la RM1x, la conectais a un teclado controlador no? Supongo que habreis probado a tocar acordes, es que asi en notas individuales no me falla, lo malo es con los acordes, no se,...
Subir
cronico
#22 por cronico el 01/06/2005
Bueno, la raiz del problema creo que ya la tengo localizada, he probado otro teclado con la RM1x y va perfecta aqui lo explico mas ampliamente https://www.hispasonic.com/tema63984-0-asc-30.html conclusion, quizas el teclado manda mensajes midi demasiado complejos para la RM1x por ser mas antigua que este.
La solucion pasa por cambiar de teclado, cosa que no me gustaria,....o interponer un hub o merger midi entre el teclado y la RM1x que haga el papel del PC o sea adaptar la señal para que la entienda la RM1x, no se, le veis sentido?
Subir
louvega
#23 por louvega el 01/06/2005
La yamaha deberia entender el teclado perfectamente. Acabo de combrobarlo y a mi no se me corta nada.

A ver, yo no se si cambiar el teclado sera la solucion. Me he estado fijando en las fotos del teclado, y tiene un interruptor detras en el cual eliges cual es el tipo de fuente de alimentacion: si el USB o el transformador. ¿no sera q eliges la opcion equivocada cuando lo tienes sin conectar al ordenador (la de USB) y al conectarlo recibe la corriente y por eso funciona?

Ya se q es mas o menos lo q ya dije y comprobaste, pero es q no se me ocurre nada mas. Vuelve a comprobarlo, por favor.

Tambien he visto q yo tengo q elegir el canal midi a atacar desde el teclado, mira q no sea algo de eso. Prueba cambiando de canal midi (en el teclado) y de sonido/patron en la yamaha, mira q no tengas puesto un sonido con un decay muy corto y por eso no tire. Ya se q son chorradas, pero es por ir probando y descartando cosas.

Una ultima comprobacion: prueba si te funciona conectandolo al pc (usb) y a la yamaha (midi) pero sin abrir el Cubase. Eso significaria q los mensajes midi del teclado van directamente a la yamaha y no pasan por el pc en ningun momento (cosa q creo q es asi). Si este fuese el caso seguramente el problema tendria q ver con la fuente de alimentacion (?).

Ya se q habras probado todo esto ya, pero vuelve a hacerlo. Y reinicia todo antes de hacerlo. La verdad es q esto es todo un misterio (-:
Subir
cronico
#24 por cronico el 02/06/2005
Tranqui louvega, no son chorradas para nada eh ;) en cualquier detallito tonto puede estar el problema, cualquier idea es bienvenida :)
Te cuento, eso que me dices del interruptor con dos posiciones, lo tenia el Radium 61 que tenia antes pero este solo tiene ON/OFF, supongo que si detecta que esta el USB alimentara por el USB y si no por el alimentador adicional, no se como lo hace la verdad,...
Eso de elegir el canal midi si que lo he probado, en todos los canales me pasa lo mismo :(
El sonido del patron suena bien al pasar la señal por el PC, asi que deberia sonar bien directo tambien.
La ultima comprobacion no la entiendo bien, dices que conecte el teclado por USB y el midi IN de la yamaha por MIDI al OUT de la tarjeta de sonido, los dos al PC no? y que no utilice el Cubasis. Pero asi he probado y los mensajes no pasan a la RM1x, ya que no le he indicado ningun ruteo midi interno,...
Necesito usar un soft para eso y tanto usando Cubasis como cualquier otro que tengo, va bien,...
Con tu teclado quizas todo va bien porque es algo mas antiguo o quizas la fabricacion es distinta al mio, no se,..
Gracias por tu ayuda
Un saludo :-)
Subir
louvega
#25 por louvega el 02/06/2005
La ultima comprobacion viene a ser la misma conexion q haces siempre: el teclado via usb al pc, y el midi out del teclado al midi in de la rm1x. Todo sin transformador. La diferencia seria no encender el Cubase en el pc. Los mensajes midi deberian llegar a la rm1x. Si esto es asi y va bien, yo diria q el problema es de la alimentacion del transformador.

En todo caso deberias mirar si conoces a alguien con otro teclado midi o otra rm1x (o modulo de sonido) y probar tu equipo con el suyo. A lo mejor los de alfasoni se enrollan y te echan una mano, aunque yo no contaria con eso. Ya mas no se me ocurre nada.

A lo mejor realmente es un problema del teclado, ahora ya me lo creo todo (:. ¿Tienes otro modulo en el q probar el teclado? Prueba si no conectarlo al midi in de tu tarjeta del pc y con un virtual, todo esto sin conectar el usb. A ver si asi se cortan las notas tambien.

No te desanimes, y a seguir probando. Hasta luego!
Subir
cronico
#26 por cronico el 02/06/2005
Esa conexion que me comentas sin transformador si, la he probado tambien, sin en el interfaz usb-midi del teclado activado, este manda los datos directos por el cable midi a la rm1x y va mal, tambien manda datos via usb al pc, pero como no abro el cubasis pues nada, no se interpretan. Si activo el interfaz usb-midi para que la rm1x reciba del PC los que le mando desde el teclado por el usb, no se puede hacer si no tengo un soft que me rutee la entrada de datos por el usb al mismo usb de vuelta para el teclado y luego a la rm1x,...:(
He quedado hoy con Proty y he probado su teclado con la rm1x y todo bien, asi que cosa, del teclado, pero porque este teclado manda perfectamente tanto a traves de midi como de usb al PC? ahi esta el quid, jeje
Esa prueba que dices de conectar el midi, sin usb al PC tambien la he hecho y todo bien, no se entrecortan las notas,...
Sigo con ello, ahora voy a probar interponiendo un hub midi o similar entre el teclado y la rm1x, a ver si adapta la señal para que la entienda bien la rm1x,..., otra opcion es encontrar a alguien, o en alguna tienda que me dejen probar otro teclado como el mio con la rm1x, a ver si es defecto del teclado o es que simplemente hay una incompatibilidad entre estos dos hardwares por ser de distintas epocas de fabricacion, no se, a ver que pasa
Salu2 :)
Subir
cronico
#27 por cronico el 09/06/2005
y el expediente X sigue,..., acabo de venir de probar la maquina con un teclado igual que el mio, que me ha dejado probar David, del distribuidor de M-Audio aqui en Zaragoza, un tio muy majo que se ha quedao flipando con mis problemas xD
El teclado que hemos probado tb fallaba con la rm1x, el keystation 49 q tb tenia alli fallaba tb, un ozone iba bien y un keystation 88 tb iba bien, que me lo expliquen, esta maquina es caprichosa de cojones, porq con el Fatar de Proty tb iba bien, no se, no tiene logica,...y esos teclados de la tienda iban bien, que los hemos probado con un modulo xv5050 de Roland (por cierto que sonidacos comparaos con la rm1x suena de pm, jeje)y el caso es q como os digo si conecto mi teclado al pc y de ahi ruteo el midi de vuelta a la maquina va todo bien, no se, la unica conclusion logica q puedo sacar de esto es que la maquina tiene algo mal en el midi que le hace fallar con unos y con otros no, no se la verda,....

Salu2 :)
Subir
texvo
#28 por texvo el 09/06/2005
hola:

te quedan dos soluciones, poner algo por medio, por ejemplo una Box de las de m-audio con dos entradas dos salidas, cuastan sobre los 50€.. es posible que las encuentres de segunda mano mas barata, pero claro cualquiera se arriesga a que funcione o no el invento o cambiar de teclado.

son de esos problemas raros que dan la lata, lata... ;)

limpia el conector de entrada midi en la rmx. ya se que seguro no tiene nada que ver... pero...

puedes incluso hacerte un cable din-din (midi) y ponerle una resistencia de 1k en serie al polo de datos, esto estabilizaria la intensidad... es posible que funcione.... (si quieres el esquema tendria me mirarlo) pero tampoco te garantizo nada.....
Subir
cronico
#29 por cronico el 09/06/2005
Ya te digo macho, desesperao estoy :?
Lo de limpiar los conectores tb lo he probado y na :(
Habia pensado en hacerme un midi thru con un in y un out, con el esquema este de la imagen, parece facil o tb eso que dices, aunque no entiendo muy bien como la resistencia en seria estabilizara la intensidad, si acaso recuducira el voltaje no? no se, si tienes por ahi el esquema, agradezco cualquier idea :)
Lo que pasa que no se si todo esto funcionara, ya t digo cuando ruteo la señal por el pc todo bien, pero en la tienda de M-audio hemos probado a conectar el teclado al modulo Roland y luego por el trhu de este sacar a la rm1x, pero nada, asi fallaba tb, desde luego no compro na mas, salvo que lo pruebe antes, jeje
a ver si dejo de gastarme pasta, cambiar de cacharros, aprenderme specs de memoria y empiezo a hacer algo ya! :evil:
Un saludo y gracias por el interes ;)
Subir
texvo
#30 por texvo el 09/06/2005
hola:

en el cable dentro del jack din poner una resistencia de 1k en el pin 4 que coresponderia con la R1, tambien a R4 R5 etc.R11. esas resistencias estabilizan la intendidad de salda de corriente, si le pusiesemos una de 1k es posible que se consiguiese una emision mas uniforme.

lo comento por que he visto esquemas de cables que llevan esa resistencia.
Subir

Hilos similares

Respuesta rápida

Regístrate o para poder postear en este hilo